summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--makefile.shared.mt8
-rw-r--r--makefile.shared.st4
4 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dbf802f45bfb..f5ecb5c514ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = atlas-lapack
pkgdesc = Complete LAPACK and BLAS implementation using optimised ATLAS routines
pkgver = 3.10.2
- pkgrel = 1
+ pkgrel = 2
url = http://math-atlas.sourceforge.net/
install = atlas-lapack.install
arch = i686
@@ -32,8 +32,8 @@ pkgbase = atlas-lapack
md5sums = a4e21f343dec8f22e7415e339f09f6da
md5sums = 38b6acb8ed5691d25863319d30a8b365
md5sums = 4903eb06072dfbf94710691ccb6660bf
- md5sums = 471f0ecdc36ef5e1118309847d142eea
- md5sums = 6e307b98236ff319ac1c03166ad9164c
+ md5sums = 2532ea5fdd412414a438b65b49451574
+ md5sums = 24dfa225d311585d79dcf2560a9682b5
pkgname = atlas-lapack
diff --git a/PKGBUILD b/PKGBUILD
index 096aa676e56f..1f3e7912559a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=atlas-lapack
pkgver=3.10.2
_lapackver=3.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Complete LAPACK and BLAS implementation using optimised ATLAS routines"
url="http://math-atlas.sourceforge.net/"
depends=('gcc-libs')
@@ -22,8 +22,8 @@ md5sums=('b1d3e3e425b2e44a06760ff173104bdf'
'a4e21f343dec8f22e7415e339f09f6da'
'38b6acb8ed5691d25863319d30a8b365'
'4903eb06072dfbf94710691ccb6660bf'
- '471f0ecdc36ef5e1118309847d142eea'
- '6e307b98236ff319ac1c03166ad9164c')
+ '2532ea5fdd412414a438b65b49451574'
+ '24dfa225d311585d79dcf2560a9682b5')
build() {
cd "$srcdir"
@@ -33,6 +33,7 @@ build() {
#USE_ARCH_DEFAULTS="yes"
msg 'Before building this package, as root you must set the CPU(s)'
msg 'governor(s) to "performance".'
+ msg 'See: https://wiki.archlinux.org/index.php/CPU_frequency_scaling'
if [ "$CARCH" = "x86_64" ]; then
ARCHITECTURE_BUILD_OPTS="-b 64" # for x86_64
diff --git a/makefile.shared.mt b/makefile.shared.mt
index 4d8e8d6f3333..9b12b97738ef 100644
--- a/makefile.shared.mt
+++ b/makefile.shared.mt
@@ -16,13 +16,13 @@ libptf77blas.so : libptf77blas.a libatlas.so
ld $(LDFLAGS) -shared -soname libblas.so.3 -o $@ --whole-archive \
libptf77blas.a --no-whole-archive $(F77SYSLIB) -L. -latlas
-libstcblas.so : libcblas.a libatlas.so
+libstcblas.so : libcblas.a libatlas.so libblas.so
ld $(LDFLAGS) -shared -soname libstcblas.so -o $@ --whole-archive \
- libcblas.a -L. -latlas
+ libcblas.a -L. -latlas -lblas
-libptcblas.so : libptcblas.a libatlas.so
+libptcblas.so : libptcblas.a libatlas.so libblas.so
ld $(LDFLAGS) -shared -soname libcblas.so -o $@ --whole-archive \
- libptcblas.a -L. -latlas
+ libptcblas.a -L. -latlas -lblas
libblas.so: libptf77blas.so
ln -s $< $@
diff --git a/makefile.shared.st b/makefile.shared.st
index 3e16e7485f6c..d3911dab2acc 100644
--- a/makefile.shared.st
+++ b/makefile.shared.st
@@ -11,9 +11,9 @@ libf77blas.so : libf77blas.a libatlas.so
ld $(LDFLAGS) -shared -soname libblas.so.3 -o $@ --whole-archive \
libf77blas.a --no-whole-archive $(F77SYSLIB) -L. -latlas
-libcblas.so : libcblas.a libatlas.so
+libcblas.so : libcblas.a libatlas.so libblas.so
ld $(LDFLAGS) -shared -soname $@ -o $@ --whole-archive libcblas.a \
- -L. -latlas
+ -L. -latlas -lblas
libblas.so: libf77blas.so
ln -s $< $@