summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD23
-rw-r--r--atmos-weather.sh21
3 files changed, 40 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 092b4f849f2b..1d13eebc807d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = atmos-weather-bin
pkgdesc = A lightweight weather app for receiving alerts and forecasts in the US.
- pkgver = 2.0.2
- pkgrel = 3
+ pkgver = 2.1.0
+ pkgrel = 1
url = https://atticuscornett.github.io/AtmosWeather/
arch = aarch64
arch = armv7h
arch = x86_64
license = GPL-3.0-only
- depends = electron28
- provides = atmos-weather=2.0.2
+ depends = electron29
+ provides = atmos-weather=2.1.0
conflicts = atmos-weather
source = atmos-weather.sh
- sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
- source_aarch64 = atmos-weather-2.0.2-aarch64.deb::https://github.com/atticuscornett/AtmosWeather/releases/download/v2.0.2/atmos-weather-linux-arm64.deb
- sha256sums_aarch64 = daa9d166b30855842d0a54ec4bff41539061d08274a3b386623ce72520dc74fc
- source_armv7h = atmos-weather-2.0.2-armv7h.deb::https://github.com/atticuscornett/AtmosWeather/releases/download/v2.0.2/atmos-weather-linux-armv7l.deb
- sha256sums_armv7h = 4a71beffd23fcecb8fc857e01af93029ef307ed975f1f5adabe8a1bb965d3431
- source_x86_64 = atmos-weather-2.0.2-x86_64.deb::https://github.com/atticuscornett/AtmosWeather/releases/download/v2.0.2/atmos-weather-linux-amd64.deb
- sha256sums_x86_64 = 626483694f7c3d9af3408f93424e8c5c4b7dc1056a09c4a6c328a9eb8846d5b9
+ sha256sums = 41b6d61dffef064762b3eec3dfeca7a3e1f57cbcb6dce9a6940c06797a0eae9d
+ source_aarch64 = atmos-weather-2.1.0-aarch64.deb::https://github.com/atticuscornett/AtmosWeather/releases/download/v2.1.0/atmos-weather_2.1.0_arm64.deb
+ sha256sums_aarch64 = 9afc961095e3f51cef5f3a25df855dface3c505ead336bb35e453ee751484847
+ source_armv7h = atmos-weather-2.1.0-armv7h.deb::https://github.com/atticuscornett/AtmosWeather/releases/download/v2.1.0/atmos-weather_2.1.0_armv7l.deb
+ sha256sums_armv7h = ebf457ce96a2b48b6cacbf0941f1e90ccf5beb8fd676328e5e78995234821c60
+ source_x86_64 = atmos-weather-2.1.0-x86_64.deb::https://github.com/atticuscornett/AtmosWeather/releases/download/v2.1.0/atmos-weather_2.1.0_amd64.deb
+ sha256sums_x86_64 = 11a2f103e2c59ad9c4986cb69d3127285fb717cf8d6954c0ca5df5a34af1a1bc
pkgname = atmos-weather-bin
diff --git a/PKGBUILD b/PKGBUILD
index 3234408babd0..d9b15a17335f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=atmos-weather-bin
_pkgname="Atmos Weather"
-pkgver=2.0.2
-_electronversion=28
-pkgrel=3
+pkgver=2.1.0
+_electronversion=29
+pkgrel=1
pkgdesc="A lightweight weather app for receiving alerts and forecasts in the US."
arch=(
'aarch64'
@@ -19,18 +19,19 @@ depends=(
"electron${_electronversion}"
)
source=("${pkgname%-bin}.sh")
-source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-arm64.deb")
-source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-armv7l.deb")
-source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-amd64.deb")
-sha256sums=('dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
-sha256sums_aarch64=('daa9d166b30855842d0a54ec4bff41539061d08274a3b386623ce72520dc74fc')
-sha256sums_armv7h=('4a71beffd23fcecb8fc857e01af93029ef307ed975f1f5adabe8a1bb965d3431')
-sha256sums_x86_64=('626483694f7c3d9af3408f93424e8c5c4b7dc1056a09c4a6c328a9eb8846d5b9')
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_arm64.deb")
+source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_armv7l.deb")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb")
+sha256sums=('41b6d61dffef064762b3eec3dfeca7a3e1f57cbcb6dce9a6940c06797a0eae9d')
+sha256sums_aarch64=('9afc961095e3f51cef5f3a25df855dface3c505ead336bb35e453ee751484847')
+sha256sums_armv7h=('ebf457ce96a2b48b6cacbf0941f1e90ccf5beb8fd676328e5e78995234821c60')
+sha256sums_x86_64=('11a2f103e2c59ad9c4986cb69d3127285fb717cf8d6954c0ca5df5a34af1a1bc')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
- -e "s|@options@||g" \
+ -e "s|@cfgdirname@|${pkgname%-bin}|g" \
+ -e "s|@options@|env ELECTRON_OZONE_PLATFORM_HINT=auto|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*
sed "s|\"/opt/${_pkgname}/${pkgname%-bin}\"|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
diff --git a/atmos-weather.sh b/atmos-weather.sh
index 7ddcaab8d734..398398461fee 100644
--- a/atmos-weather.sh
+++ b/atmos-weather.sh
@@ -1,16 +1,29 @@
#!/bin/bash
-set -e
+set -o pipefail
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_CFGDIR="@cfgdirname@/"
_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export ELECTRON_FORCE_IS_PACKAGED=true
+export ELECTRON_DISABLE_SECURITY_WARNINGS=true
+export ELECTRON_OVERRIDE_DIST_PATH="/usr/bin/electron@electronversion@"
export NODE_ENV=production
+export XDG_CONFIG_HOME="${XDG_CONFIG_HOME:-$HOME/.config}"
+export _FLAGS_FILE="${XDG_CONFIG_HOME}/${_CFGDIR}@appname@-flags.conf"
+declare -a _USER_FLAGS
+if [[ -f "${_FLAGS_FILE}" ]]; then
+ while read -r line; do
+ if [[ ! "${line}" =~ ^[[:space:]]*#.* ]]; then
+ _USER_FLAGS+=("${line}")
+ fi
+ done < "${_FLAGS_FILE}"
+fi
cd "${_APPDIR}"
-if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
+if [[ "${EUID}" -ne 0 ]] || [[ "${ELECTRON_RUN_AS_NODE}" ]]; then
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "${_USER_FLAGS[@]}" "$@"
else
- exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "${_USER_FLAGS[@]}" "$@"
fi \ No newline at end of file