summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD69
2 files changed, 42 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22126edbae93..50b136c30962 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
-# Generated by mksrcinfo v8
-# Wed Apr 11 19:32:44 UTC 2018
pkgbase = audiotools-git
pkgdesc = Collection of audio handling programs which work from the command line (GIT Version)
- pkgver = v3.1.1.127.g88d31ac3
+ pkgver = 3.1.1.129.gde55488d
pkgrel = 1
url = http://audiotools.sourceforge.net
arch = x86_64
license = GPL
makedepends = git
makedepends = python-setuptools
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-build
depends = python
depends = libcdio-paranoia
depends = libpulse
@@ -37,4 +38,3 @@ pkgbase = audiotools-git
sha1sums = SKIP
pkgname = audiotools-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 1e17410be942..c7c8facb255f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,45 @@
# Maintainer: Guatavo Alvarez <sl1pkn07@gmail.com>
pkgname=audiotools-git
-pkgver=v3.1.1.127.g88d31ac3
+pkgver=3.1.1.129.gde55488d
pkgrel=1
pkgdesc="Collection of audio handling programs which work from the command line (GIT Version)"
arch=('x86_64')
url='http://audiotools.sourceforge.net'
license=('GPL')
-depends=('python'
- 'libcdio-paranoia'
- 'libpulse'
- 'opusfile'
- 'twolame'
- 'mpg123'
- 'lame'
- 'wavpack'
- 'libdvd-audio-git'
- )
-makedepends=('git'
- 'python-setuptools'
- )
-optdepends=('faad2: Decoding AAC'
- 'faac: Encoding AAC'
- 'neroaacdec: Decoding AAC (preferred)'
- 'neroaacenc: Encoding AAC (preferred)'
- 'mp3gain: For MP3 Replay Gain support'
- 'vorbisgain: For OGG Replay Gain support'
- 'python-pillow: for Coverview interface'
- 'pygtk: for Coverview interface (GTK)'
- 'python-pmw: Coverview interface (Tk)'
- 'python-urwid: interactive modes'
- 'cdrkit: for CD burning without cuesheets'
- 'cdrtools: for CD burning without cuesheets'
- 'cdrdao: for CD burning with cuesheets'
- )
+depends=(
+ 'python'
+ 'libcdio-paranoia'
+ 'libpulse'
+ 'opusfile'
+ 'twolame'
+ 'mpg123'
+ 'lame'
+ 'wavpack'
+ 'libdvd-audio-git'
+)
+makedepends=(
+ 'git'
+ 'python-setuptools'
+ 'python-installer'
+ 'python-wheel'
+ 'python-build'
+)
+optdepends=(
+ 'faad2: Decoding AAC'
+ 'faac: Encoding AAC'
+ 'neroaacdec: Decoding AAC (preferred)'
+ 'neroaacenc: Encoding AAC (preferred)'
+ 'mp3gain: For MP3 Replay Gain support'
+ 'vorbisgain: For OGG Replay Gain support'
+ 'python-pillow: for Coverview interface'
+ 'pygtk: for Coverview interface (GTK)'
+ 'python-pmw: Coverview interface (Tk)'
+ 'python-urwid: interactive modes'
+ 'cdrkit: for CD burning without cuesheets'
+ 'cdrtools: for CD burning without cuesheets'
+ 'cdrdao: for CD burning with cuesheets'
+)
conflicts=('audiotools')
provides=('audiotools')
source=('audiotools::git+https://github.com/tuffy/python-audio-tools.git')
@@ -41,7 +47,7 @@ sha1sums=('SKIP')
pkgver() {
cd audiotools
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
}
prepare() {
@@ -54,12 +60,13 @@ prepare() {
build() {
cd audiotools
- python setup.py build
+ python -m build --wheel --no-isolation
make -C docs
}
package() {
cd audiotools
- python setup.py install --root="${pkgdir}" --optimize=1
+ python -m installer --destdir="${pkgdir}" dist/*.whl
make -C docs install MAN_PATH="${pkgdir}/usr/share/man"
+ rm -fr "${pkgdir}/usr/share/man/man1/audiotools.cfg.5.gz"
}