summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf692ad019f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = austin-git
+ pkgdesc = Python frame stack sampler for CPython
+ pkgver = v2.1.1.r0.g2f29bd7
+ pkgrel = 1
+ url = https://github.com/P403n1x87/austin
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ provides = austin
+ conflicts = austin
+ source = git+https://github.com/P403n1x87/austin
+ sha1sums = SKIP
+
+pkgname = austin-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1926e6c68839
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+
+pkgname=austin-git
+pkgver=v2.1.1.r0.g2f29bd7
+pkgrel=1
+pkgdesc='Python frame stack sampler for CPython'
+arch=('x86_64' 'armv7h' 'aarch64')
+url='https://github.com/P403n1x87/austin'
+license=('GPL3')
+makedepends=('git')
+conflicts=('austin')
+provides=("austin")
+
+source=('git+https://github.com/P403n1x87/austin')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd austin
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd austin
+ autoreconf --install
+ mkdir build
+}
+
+build() {
+ cd austin/build
+ ../configure --prefix=/usr
+ make
+}
+
+package() {
+ cd austin/build
+ make DESTDIR="$pkgdir" install
+}