summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca3952dfdf12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = auth-get-sso-cookie
+ pkgdesc = auth-get-sso-cookie acquires CERN Single Sign-On cookie using Kerberos credentials allowing for automated access to CERN SSO protected pages using tools alike wget, curl or similar.
+ pkgver = 2.2.0
+ pkgrel = 1
+ url = https://gitlab.cern.ch/authzsvc/docs/auth-get-sso-cookie
+ arch = any
+ license = MIT
+ makedepends = python-installer
+ depends = python-requests-gssapi
+ source = https://files.pythonhosted.org/packages/py3/a/auth-get-sso-cookie/auth_get_sso_cookie-2.2.0-py3-none-any.whl
+ sha256sums = 0e0668fb71339f0150d71248200c847ede3e60d0dac5fa15f4ace9caa4b613aa
+
+pkgname = auth-get-sso-cookie
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eca5d6d8b86d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Wainer Vandelli <wainer dot vandelli at gmail dot com>
+pkgname=auth-get-sso-cookie
+pkgver=2.2.0
+pkgrel=1
+pkgdesc="auth-get-sso-cookie acquires CERN Single Sign-On cookie using Kerberos credentials allowing for automated access to CERN SSO protected pages using tools alike wget, curl or similar."
+arch=("any")
+url="https://gitlab.cern.ch/authzsvc/tools/auth-get-sso-cookie"
+license=("MIT")
+depends=("python-requests-gssapi")
+makedepends=("python-installer")
+_name=$pkgname
+source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/${_name//-/_}-$pkgver-py3-none-any.whl")
+sha256sums=('0e0668fb71339f0150d71248200c847ede3e60d0dac5fa15f4ace9caa4b613aa')
+
+package() {
+ cd "$srcdir"
+ python -m installer --destdir="$pkgdir" *.whl
+}
+