summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 863c412cce91..0dbedb4b5012 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = autokey
pkgver = 0.95.10
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/autokey/autokey
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index e1c70250a007..ce2933fc2760 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=('autokey-common' 'autokey-gtk' 'autokey-qt')
pkgbase=autokey
pkgver=0.95.10
-pkgrel=2
+pkgrel=3
arch=('i686' 'x86_64')
url="https://github.com/autokey/autokey"
license=('GPL3')
@@ -15,6 +15,13 @@ sha256sums=('e622ca04b3340f1ca0999bf03f05c9071a9f8aa3bc91c26c45c35509d63ff23d')
build() {
cd "$pkgbase-$pkgver"
python setup.py build
+
+ # remove shebang from python libraries
+ for lib in $(find lib/autokey/ -name "*.py"); do
+ sed '/\/usr\/bin\/env/d' $lib > $lib.new &&
+ touch -r $lib $lib.new &&
+ mv $lib.new $lib
+ done
}
package_autokey-common() {