summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
-rw-r--r--automake.install22
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7181150b5b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = automake-1.7
+ pkgdesc = A GNU tool for automatically creating Makefiles
+ pkgver = 1.7.9
+ pkgrel = 1
+ url = http://www.gnu.org/software/automake
+ install = automake.install
+ arch = any
+ groups = base-devel
+ license = GPL
+ makedepends = autoconf
+ depends = perl
+ depends = bash
+ provides = automake=1.7
+ options = !emptydirs
+ source = ftp://ftp.gnu.org/gnu/automake/automake-1.7.9.tar.gz
+ md5sums = eb25355e3cf00aac83c580dde970a0b4
+
+pkgname = automake-1.7
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12e880a23675
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
+# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+
+pkgname=automake-1.7
+_pkgname=automake
+pkgver=1.7.9
+pkgrel=1
+pkgdesc="A GNU tool for automatically creating Makefiles"
+arch=('any')
+license=('GPL')
+url="http://www.gnu.org/software/automake"
+groups=('base-devel')
+depends=('perl' 'bash')
+makedepends=('autoconf')
+provides=("automake=1.7")
+options=(!emptydirs)
+install='automake.install'
+source=("ftp://ftp.gnu.org/gnu/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+
+build() {
+ cd "$srcdir"/${_pkgname}-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package(){
+ cd "$srcdir"/${_pkgname}-$pkgver
+ make DESTDIR="$pkgdir" install
+
+ # remove the symlinks
+ rm "$pkgdir"/usr/bin/{automake,aclocal}
+
+ # make info files version specific
+ install -dm755 "$pkgdir"/usr/share/info
+ mv "$pkgdir"/usr/info/${_pkgname}.info "$pkgdir"/usr/share/info/${_pkgname}-1.7.info
+}
+md5sums=('eb25355e3cf00aac83c580dde970a0b4')
diff --git a/automake.install b/automake.install
new file mode 100644
index 000000000000..caad26849dea
--- /dev/null
+++ b/automake.install
@@ -0,0 +1,22 @@
+infodir=/usr/share/info
+filelist=(automake-1.7.info)
+
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file.gz $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file.gz $infodir/dir 2> /dev/null
+ done
+}
+
+# vim:set ts=2 sw=2 et: