summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
-rw-r--r--autopass.service5
-rw-r--r--autopass.socket9
4 files changed, 35 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44284d58825c..a32b9e383c3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Aug 15 09:35:05 UTC 2019
+# Fri Nov 15 15:00:14 UTC 2019
pkgbase = autopass.cr-git
pkgdesc = a rofi frontend for pass
- pkgver = 0.r4.802fb81
- pkgrel = 3
+ pkgver = 0.r14.ed2280b
+ pkgrel = 2
url = https://gitlab.com/repomaa/autopass.cr
arch = x86_64
license = MIT
@@ -23,6 +23,10 @@ pkgbase = autopass.cr-git
provides = autopass
conflicts = autopass
source = autopass.cr-git::git+https://gitlab.com/repomaa/autopass.cr
+ source = autopass.socket
+ source = autopass.service
+ sha512sums = SKIP
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = autopass.cr-git
diff --git a/PKGBUILD b/PKGBUILD
index 6af6eaabaa60..ca383ff90bd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Joakim Repomaa <aur@j.repomaa.com>
pkgname=autopass.cr-git
-pkgver=0.r4.802fb81
-pkgrel=3
+pkgver=0.r14.ed2280b
+pkgrel=2
pkgdesc='a rofi frontend for pass'
arch=(x86_64)
url='https://gitlab.com/repomaa/autopass.cr'
@@ -10,8 +10,16 @@ license=('MIT')
depends=(pass rofi xdotool gpgme gc libyaml libevent)
makedepends=(crystal shards rust git python)
-source=("${pkgname}::git+https://gitlab.com/repomaa/autopass.cr")
-sha512sums=(SKIP)
+source=(
+ "${pkgname}::git+https://gitlab.com/repomaa/autopass.cr"
+ 'autopass.socket'
+ 'autopass.service'
+)
+sha512sums=(
+ SKIP
+ SKIP
+ SKIP
+)
provides=('autopass')
conflicts=('autopass')
optdepends=('passed-git: batch editing of pass entries with sed')
@@ -31,6 +39,8 @@ package() {
install -d "$pkgdir/usr/bin"
install -m755 bin/autopass "$pkgdir/usr/bin/autopass"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 autopass.socket "$pkgdir/usr/lib/systemd/user/autopass.socket"
+ install -Dm644 autopass.service "$pkgdir/usr/lib/systemd/user/autopass.service"
}
# vim:set ts=2 sw=2 et:
diff --git a/autopass.service b/autopass.service
new file mode 100644
index 000000000000..a38799ad01b9
--- /dev/null
+++ b/autopass.service
@@ -0,0 +1,5 @@
+[Unit]
+Description=Socket activated autopass
+
+[Service]
+ExecStart=/usr/bin/autopass
diff --git a/autopass.socket b/autopass.socket
new file mode 100644
index 000000000000..188e39351b79
--- /dev/null
+++ b/autopass.socket
@@ -0,0 +1,9 @@
+[Unit]
+Description=Socket activation for autopass
+
+[Socket]
+ListenFIFO=%t/autopass.fifo
+SocketMode=0600
+
+[Install]
+WantedBy=default.target