summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
-rw-r--r--systemd-unit-dir.patch17
3 files changed, 8 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 620bd95eadaa..a9e6aca1c222 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = autorandr-git
pkgdesc = Auto-detect the connect display hardware and load the appropiate X11 setup using xrandr. Formerly autodisper. No disper support.
- pkgver = r210.582290b
+ pkgver = r240.53d29f9
pkgrel = 1
url = https://github.com/phillipberndt/autorandr
install = autorandr-git.install
@@ -19,10 +19,8 @@ pkgbase = autorandr-git
conflicts = autorandr-phillipberndt-git
source = autorandr::git+https://github.com/phillipberndt/autorandr.git
source = autorandr-git.install
- source = systemd-unit-dir.patch
- md5sums = SKIP
- md5sums = bedb41a350cdf6983872119aef71fed6
- md5sums = 04ccd2e108878ee07fbb3282a3f7f75f
+ sha256sums = SKIP
+ sha256sums = 60c035d6f433d388ef1d3acec084dcd021158cbec79e9807e78cc368cb499690
pkgname = autorandr-git
diff --git a/PKGBUILD b/PKGBUILD
index f12373f99095..3fd32b7d5882 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: James An <james@jamesan.ca>
+# Maintainer: Edgard Castro <castro@edgard.org>
+# Contributor: James An <james@jamesan.ca>
# Contributor: Helge Willum Larsen <helgesdk@gmail.com>
# Contributor: Ng Oon-Ee <ngoonee.talk@gmail.com>
# Contributor: Byron Clark <byron@theclarkfamily.name> (auto-disper-git)
@@ -7,7 +8,7 @@
_pkgname=autorandr
pkgname=autorandr-git
-pkgver=r210.582290b
+pkgver=r240.53d29f9
pkgrel=1
pkgdesc='Auto-detect the connect display hardware and load the appropiate X11 setup using xrandr. Formerly autodisper. No disper support.'
arch=('any')
@@ -31,11 +32,9 @@ install="$pkgname.install"
source=(
"$_pkgname"::"git+https://github.com/phillipberndt/$_pkgname.git"
"$pkgname.install"
- systemd-unit-dir.patch
)
-md5sums=('SKIP'
- 'bedb41a350cdf6983872119aef71fed6'
- '04ccd2e108878ee07fbb3282a3f7f75f')
+sha256sums=('SKIP'
+ '60c035d6f433d388ef1d3acec084dcd021158cbec79e9807e78cc368cb499690')
pkgver() {
cd "$_pkgname"
@@ -46,11 +45,6 @@ pkgver() {
) 2>/dev/null
}
-prepare() {
- cd "$_pkgname"
- patch -p1 -i ../systemd-unit-dir.patch
-}
-
package() {
cd "$_pkgname"
make DESTDIR="$pkgdir" PREFIX=/usr install
diff --git a/systemd-unit-dir.patch b/systemd-unit-dir.patch
deleted file mode 100644
index bc5185614c2c..000000000000
--- a/systemd-unit-dir.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 42ee710..4803d8d 100644
---- a/Makefile
-+++ b/Makefile
-@@ -51,10 +51,10 @@ DEFAULT_TARGETS+=systemd
- endif
-
- install_systemd: install_pmutils
-- install -D -m 644 contrib/systemd/autorandr-resume.service ${DESTDIR}/etc/systemd/system/autorandr-resume.service
-+ install -D -m 644 contrib/systemd/autorandr-resume.service ${DESTDIR}$(shell pkg-config systemd --variable=systemdsystemunitdir)/autorandr-resume.service
-
- uninstall_systemd: uninstall_pmutils
-- rm -f ${DESTDIR}/etc/systemd/system/autorandr-resume.service
-+ rm -f ${DESTDIR}$(shell pkg-config systemd --variable=systemdsystemunitdir)/autorandr-resume.service
-
- # Rules for udev
- HAVE_UDEV=$(shell [ -d /etc/udev/rules.d/ ] && echo "y")