summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD38
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22f477fddf11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = avxsynth-plugin-depan-git
+ pkgdesc = Plugin for Avxsynth. depan (GIT)
+ pkgver = 1.11.0.1.ga5f2b95
+ pkgrel = 1
+ url = https://github.com/btb/depan
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = avxsynth
+ depends = fftw
+ provides = avxsynth-plugin-depan
+ conflicts = avxsynth-plugin-depan
+ source = depan::git+https://github.com/btb/depan.git
+ md5sums = SKIP
+
+pkgname = avxsynth-plugin-depan-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..623d0e70ff3e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..009d9d77363a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=depan
+pkgname=avxsynth-plugin-${_plug}-git
+pkgver=1.11.0.1.ga5f2b95
+pkgrel=1
+pkgdesc="Plugin for Avxsynth. ${_plug} (GIT)"
+arch=('i686' 'x86_64')
+url="https://github.com/btb/depan"
+license=('GPL')
+depends=('avxsynth' 'fftw')
+makedepends=('git' 'cmake')
+provides=("avxsynth-plugin-${_plug}")
+conflicts=("avxsynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/btb/depan.git")
+md5sums=('SKIP')
+_gitname="${_plug}"
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | sed 's|depan-||g' | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake "../${_plug}" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package(){
+ make -C build DESTDIR="${pkgdir}" install
+}
+