summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f47deebb9c49..01a431895c0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = aws-sam-cli
pkgdesc = CLI tool to build, test, debug, and deploy Serverless applications using AWS SAM
- pkgver = 1.112.0
+ pkgver = 1.116.0
pkgrel = 1
url = https://github.com/aws/aws-sam-cli
arch = any
license = Apache
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = docker
depends = python-aws-lambda-builders
depends = python-aws-sam-translator
@@ -23,7 +25,7 @@ pkgbase = aws-sam-cli
depends = python-rich
depends = python-ruamel-yaml
depends = python-tomlkit
- depends = python-typing-extensions
+ depends = python-typing_extensions
depends = python-watchdog
depends = python-yaml
depends = python-mypy-boto3-apigateway
@@ -41,7 +43,7 @@ pkgbase = aws-sam-cli
depends = python-mypy-boto3-kinesis
depends = python-mypy-boto3-sqs
options = !emptydirs
- source = https://files.pythonhosted.org/packages/source/a/aws-sam-cli/aws-sam-cli-1.112.0.tar.gz
- sha256sums = c45aa225380bee8d508d03c4ae5ee98a55669daea7361a235da9e8b023c50cbe
+ source = https://files.pythonhosted.org/packages/source/a/aws-sam-cli/aws_sam_cli-1.116.0.tar.gz
+ sha256sums = 34c55aafb038b3d588a557d08370e0548297f52276972cf9e5f8618643b4eeef
pkgname = aws-sam-cli
diff --git a/PKGBUILD b/PKGBUILD
index c9ca58a1f51f..07c3df6261bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
# Contributor: Aaron Miller <aaronm@cldtk.com>
pkgname=aws-sam-cli
-pkgver=1.112.0
+_name=$pkgname
+pkgver=1.116.0
pkgrel=1
pkgdesc='CLI tool to build, test, debug, and deploy Serverless applications using AWS SAM'
arch=('any')
@@ -11,19 +12,23 @@ license=('Apache')
depends=('docker' 'python-aws-lambda-builders' 'python-aws-sam-translator' 'python-boto3' 'python-cfn-lint'
'python-chevron' 'python-click' 'python-cookiecutter' 'python-dateparser' 'python-docker' 'python-flask'
'python-jmespath' 'python-pyopenssl' 'python-requests' 'python-rich' 'python-ruamel-yaml' 'python-tomlkit'
- 'python-typing-extensions' 'python-watchdog' 'python-yaml' 'python-mypy-boto3-apigateway'
+ 'python-typing_extensions' 'python-watchdog' 'python-yaml' 'python-mypy-boto3-apigateway'
'python-mypy-boto3-cloudformation' 'python-mypy-boto3-ecr' 'python-mypy-boto3-iam' 'python-mypy-boto3-lambda'
'python-mypy-boto3-s3' 'python-mypy-boto3-schemas' 'python-mypy-boto3-secretsmanager'
'python-mypy-boto3-signer' 'python-mypy-boto3-stepfunctions' 'python-mypy-boto3-sts' 'python-mypy-boto3-xray'
'python-mypy-boto3-kinesis' 'python-mypy-boto3-sqs'
)
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel')
options=(!emptydirs)
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('c45aa225380bee8d508d03c4ae5ee98a55669daea7361a235da9e8b023c50cbe')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/${_name//-/_}-$pkgver.tar.gz")
+sha256sums=('34c55aafb038b3d588a557d08370e0548297f52276972cf9e5f8618643b4eeef')
-package() {
- cd "$pkgname-$pkgver"
+build() {
+ cd "${_name//-/_}-$pkgver"
+ python -m build --wheel --no-isolation
+}
- /usr/bin/python setup.py install --root="$pkgdir/" --optimize=1
+package() {
+ cd "${_name//-/_}-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}