summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD44
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e484cbe4a27a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = backscrub-git
+ pkgdesc = Virtual video device (webcam) for background replacement / blurring
+ pkgver = v0.3.0.r63.g4f70bc1
+ pkgrel = 1
+ url = https://github.com/floe/backscrub
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = cmake
+ depends = libcurl-gnutls
+ depends = opencv
+ depends = v4l2loopback-dkms
+ provides = backscrub
+ conflicts = backscrub
+ source = backscrub-git::git+https://github.com/floe/backscrub.git
+ source = tensorflow::git+https://github.com/tensorflow/tensorflow
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = backscrub-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ba8aa1876e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Andrej Radović <r.andrej@gmail.com>
+pkgname=backscrub-git
+pkgver=v0.3.0.r63.g4f70bc1
+pkgrel=1
+pkgdesc="Virtual video device (webcam) for background replacement / blurring"
+arch=('i686' 'x86_64')
+url="https://github.com/floe/backscrub"
+makedepends=(
+ 'cmake'
+)
+depends=(
+ 'libcurl-gnutls'
+ 'opencv'
+ 'v4l2loopback-dkms'
+)
+license=('Apache')
+provides=("backscrub")
+conflicts=("backscrub")
+source=("$pkgname::git+https://github.com/floe/backscrub.git"
+ "tensorflow::git+https://github.com/tensorflow/tensorflow")
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ ls "$srcdir"
+ cmake \
+ -B "${pkgname}/build" \
+ -S "${pkgname}" \
+ -DTENSORFLOW:PATH="$srcdir/tensorflow" \
+ -DCMAKE_BUILD_TYPE:STRING='None' \
+ -DCMAKE_INSTALL_PREFIX:PATH='/usr'
+ cmake --build "${pkgname}/build"
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake \
+ --build "${pkgname}/build" \
+ --target install
+}