summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD30
2 files changed, 13 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5999e9731084..b4f6b678262a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = baikal
pkgdesc = Lightweight CalDAV+CardDAV server
- pkgver = 0.6.1
- pkgrel = 2
+ pkgver = 0.7.0
+ pkgrel = 1
url = http://sabre.io/baikal/
install = baikal.install
arch = any
@@ -11,14 +11,10 @@ pkgbase = baikal
optdepends = mariadb: Alternate database
optdepends = php-sqlite: To use the sqlite backend
options = !strip
- source = https://github.com/fruux/Baikal/releases/download/0.6.1/baikal-0.6.1.zip
+ source = https://github.com/fruux/Baikal/releases/download/0.7.0/baikal-0.7.0.zip
source = baikal.install
- source = Port-to-PHP-74.patch::https://patch-diff.githubusercontent.com/raw/sabre-io/Baikal/pull/852.patch
- source = Further-PHP-74-fix.patch::https://github.com/sabre-io/vobject/commit/40b98311c115f511891337231d592f2a0dae4d15.patch
- sha1sums = c971ee72540d85d747caf8bccd8bcfecf3502873
+ sha1sums = 5d241976c791b8f8b27cfb1569133f9aa36c56c1
sha1sums = deb948e61c3cd8d6ad560321f78c0b288f7a6210
- sha1sums = 39bcef492e415cf305afddd5d7918d861fde7b8a
- sha1sums = 64cd91a8ca19c43fe14ec3f90ceba063fe3311e3
pkgname = baikal
diff --git a/PKGBUILD b/PKGBUILD
index cb3c0f30365b..82fbe2ec97e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Florian Bruhin (The Compiler) <archlinux.org@the-compiler.org>
-# vim: ft=sh
+# Maintainer: Martchus <martchus@gmx.net>
+# Contributor: Florian Bruhin (The Compiler) <archlinux.org@the-compiler.org>
pkgname=baikal
-pkgver=0.6.1
-pkgrel=2
+pkgver=0.7.0
+pkgrel=1
pkgdesc='Lightweight CalDAV+CardDAV server'
url='http://sabre.io/baikal/'
arch=('any')
@@ -11,32 +11,20 @@ license=('GPL')
depends=('php')
optdepends=('sqlite: Database' 'mariadb: Alternate database' 'php-sqlite: To use the sqlite backend')
source=("https://github.com/fruux/Baikal/releases/download/$pkgver/baikal-$pkgver.zip"
- 'baikal.install'
- 'Port-to-PHP-74.patch::https://patch-diff.githubusercontent.com/raw/sabre-io/Baikal/pull/852.patch'
- 'Further-PHP-74-fix.patch::https://github.com/sabre-io/vobject/commit/40b98311c115f511891337231d592f2a0dae4d15.patch')
-sha1sums=('c971ee72540d85d747caf8bccd8bcfecf3502873'
- 'deb948e61c3cd8d6ad560321f78c0b288f7a6210'
- '39bcef492e415cf305afddd5d7918d861fde7b8a'
- '64cd91a8ca19c43fe14ec3f90ceba063fe3311e3')
+ 'baikal.install')
+sha1sums=('5d241976c791b8f8b27cfb1569133f9aa36c56c1'
+ 'deb948e61c3cd8d6ad560321f78c0b288f7a6210')
options=('!strip')
install=baikal.install
-prepare() {
- cd "${srcdir}/baikal"
-
- patch -p1 -i "$srcdir/Port-to-PHP-74.patch"
- pushd 'vendor/sabre/vobject'
- patch -p1 -i "$srcdir/Further-PHP-74-fix.patch"
-}
-
package() {
cd "${srcdir}/baikal"
install -dm 755 "$pkgdir"/usr/share/{webapps,doc}"/$pkgname"
install -dm 700 -o http -g http "$pkgdir/var/lib/$pkgname"
+ install -dm 700 -o http -g http "$pkgdir/var/lib/$pkgname/config"
cp -R Core html vendor "$pkgdir/usr/share/webapps/$pkgname"
install -Dm644 CHANGELOG.md README.md "$pkgdir/usr/share/doc/$pkgname"
ln -s "/var/lib/$pkgname" "$pkgdir/usr/share/webapps/$pkgname/Specific"
+ ln -s "/var/lib/$pkgname/config" "$pkgdir/usr/share/webapps/$pkgname/config"
}
-
-# vim:set ts=2 sw=2 et: