summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
-rw-r--r--baikal.install8
-rw-r--r--php7.patch59
4 files changed, 22 insertions, 93 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc59f562ed5d..2db7af7faad8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Thu Jan 14 15:16:05 UTC 2016
+# Mon Feb 29 06:16:30 UTC 2016
pkgbase = baikal
pkgdesc = Lightweight CalDAV+CardDAV server
- pkgver = 0.2.7
- pkgrel = 6
- url = http://baikal-server.com/
+ pkgver = 0.3.5
+ pkgrel = 1
+ url = http://sabre.io/baikal/
install = baikal.install
arch = any
license = GPL
@@ -13,12 +13,10 @@ pkgbase = baikal
optdepends = mariadb: Alternate database
optdepends = php-sqlite: To use the sqlite backend
options = !strip
- source = http://baikal-server.com/get/baikal-regular-0.2.7.tgz
+ source = https://github.com/fruux/Baikal/releases/download/0.3.5/baikal-0.3.5.zip
source = baikal.install
- source = php7.patch
- sha1sums = 01eabcf0229ddffc0542f4e2a349754e778abbea
- sha1sums = a1d2f36b6c4a282d23477dccb957c3ad3995f116
- sha1sums = e1c586c6549f08966c101a5f5125011c5a172f12
+ sha1sums = f714fd030c2659938a5f70c3427458b8d9ce0c83
+ sha1sums = 80692b8c87873d0ec9b4f2ab336aad9b055125d8
pkgname = baikal
diff --git a/PKGBUILD b/PKGBUILD
index 6c5d05d3162d..39f5dda89446 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,41 +2,27 @@
# vim: ft=sh
pkgname=baikal
-pkgver=0.2.7
-pkgrel=6
+pkgver=0.3.5
+pkgrel=1
pkgdesc="Lightweight CalDAV+CardDAV server"
-url="http://baikal-server.com/"
+url="http://sabre.io/baikal/"
arch=('any')
license=('GPL')
depends=('php')
optdepends=('sqlite: Database' 'mariadb: Alternate database' 'php-sqlite: To use the sqlite backend')
-source=("http://baikal-server.com/get/baikal-regular-${pkgver}.tgz"
- 'baikal.install'
- 'php7.patch')
-sha1sums=('01eabcf0229ddffc0542f4e2a349754e778abbea'
- 'a1d2f36b6c4a282d23477dccb957c3ad3995f116'
- 'e1c586c6549f08966c101a5f5125011c5a172f12')
+source=("https://github.com/fruux/Baikal/releases/download/$pkgver/baikal-$pkgver.zip"
+ 'baikal.install')
+sha1sums=('f714fd030c2659938a5f70c3427458b8d9ce0c83'
+ '80692b8c87873d0ec9b4f2ab336aad9b055125d8')
options=('!strip')
install=baikal.install
-prepare() {
- cd "${srcdir}/baikal-regular"
- patch -p0 -i ../php7.patch
-}
-
package() {
- cd "${srcdir}/baikal-regular"
+ cd "${srcdir}/baikal"
install -dm 755 "$pkgdir"/usr/share/{webapps,doc}"/$pkgname"
install -dm 700 -o http -g http "$pkgdir/var/lib/$pkgname"
cp -R Core html vendor "$pkgdir/usr/share/webapps/$pkgname"
- install -Dm644 ChangeLog.md INSTALL.md README.md TROUBLESHOOTING.md \
- "$pkgdir/usr/share/doc/$pkgname"
- for conf in Specific/virtualhosts/*; do
- basename=${conf##*/}
- basename=${basename/baikal./}.example.conf
- sed 's|/var/www/dav.mydomain.com|/usr/share/webapps/baikal|' "$conf" > \
- "$pkgdir/usr/share/doc/$pkgname/$basename"
- done
+ install -Dm644 CHANGELOG.md README.md "$pkgdir/usr/share/doc/$pkgname"
ln -s "/var/lib/$pkgname" "$pkgdir/usr/share/webapps/$pkgname/Specific"
}
diff --git a/baikal.install b/baikal.install
index 2e36cb389abf..707c440ffbaf 100644
--- a/baikal.install
+++ b/baikal.install
@@ -15,7 +15,7 @@ post_install() {
echo "Please add /var/lib/baikal to open_basedir in your /etc/php.ini."
echo
echo "You also need to set up your webserver for baikal, there are example"
- echo "configs for Apache/nginx in /usr/share/doc/baikal."
+ echo "configs for Apache/nginx at http://sabre.io/baikal/install/."
echo
echo "After that, navigate to your baikal instance to complete the setup."
echo
@@ -25,9 +25,13 @@ post_install() {
}
post_upgrade() {
- if [[ $2 < '0.2.7-5' ]]; then
+ if [[ $(vercmp $2 '0.2.7-5') == -1 ]]; then
echo "Please add /var/lib/baikal to open_basedir in your /etc/php.ini."
fi
+ if [[ $(vercmp $2 0.3.0) == -1 ]]; then
+ touch /var/lib/baikal/ENABLE_INSTALL
+ echo "Navigate to your baikal instance to complete the upgrade."
+ fi
}
# vim:set ts=2 sw=2 et ft=sh:
diff --git a/php7.patch b/php7.patch
deleted file mode 100644
index 56356515133e..000000000000
--- a/php7.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-# Based on:
-# https://github.com/fruux/sabre-dav/commit/c9f3e7d2be11872eb36873c5410bac476d815871
-# https://github.com/netgusto/Baikal/issues/420#issuecomment-170257207
---- vendor/sabre/dav/lib/Sabre/CalDAV/CalendarQueryValidator.php.orig 2014-11-17 11:57:29.000000000 +0100
-+++ vendor/sabre/dav/lib/Sabre/CalDAV/CalendarQueryValidator.php 2016-01-14 16:09:17.019090596 +0100
-@@ -59,7 +59,7 @@
-
- foreach($filters as $filter) {
-
-- $isDefined = isset($parent->$filter['name']);
-+ $isDefined = isset($parent->{$filter['name']});
-
- if ($filter['is-not-defined']) {
-
-@@ -75,7 +75,7 @@
- }
-
- if ($filter['time-range']) {
-- foreach($parent->$filter['name'] as $subComponent) {
-+ foreach($parent->{$filter['name']} as $subComponent) {
- if ($this->validateTimeRange($subComponent, $filter['time-range']['start'], $filter['time-range']['end'])) {
- continue 2;
- }
-@@ -89,7 +89,7 @@
-
- // If there are sub-filters, we need to find at least one component
- // for which the subfilters hold true.
-- foreach($parent->$filter['name'] as $subComponent) {
-+ foreach($parent->{$filter['name']} as $subComponent) {
-
- if (
- $this->validateCompFilters($subComponent, $filter['comp-filters']) &&
-@@ -128,7 +128,7 @@
-
- foreach($filters as $filter) {
-
-- $isDefined = isset($parent->$filter['name']);
-+ $isDefined = isset($parent->{$filter['name']});
-
- if ($filter['is-not-defined']) {
-
-@@ -144,7 +144,7 @@
- }
-
- if ($filter['time-range']) {
-- foreach($parent->$filter['name'] as $subComponent) {
-+ foreach($parent->{$filter['name']} as $subComponent) {
- if ($this->validateTimeRange($subComponent, $filter['time-range']['start'], $filter['time-range']['end'])) {
- continue 2;
- }
-@@ -158,7 +158,7 @@
-
- // If there are sub-filters, we need to find at least one property
- // for which the subfilters hold true.
-- foreach($parent->$filter['name'] as $subComponent) {
-+ foreach($parent->{$filter['name']} as $subComponent) {
-
- if(
- $this->validateParamFilters($subComponent, $filter['param-filters']) &&