summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
-rw-r--r--bareftp-legacy.install22
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f1817289325
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = bareftp-legacy
+ pkgdesc = bareFTP a file transfer client supporting the FTP, FTPS and SFTP protocols
+ pkgver = 0.3.12
+ pkgrel = 1
+ url = http://www.bareftp.org/
+ install = bareftp-legacy.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool>=0.35
+ makedepends = pkgconfig>=0.9
+ depends = gnome-sharp>=2
+ depends = gnome-icon-theme
+ depends = gnome-keyring-sharp
+ depends = mono>=2
+ provides = bareftp
+ conflicts = bareftp
+ replaces = bareftp
+ source = http://www.bareftp.org/release/bareftp-0.3.12.tar.gz
+ sha256sums = efb22c6b03a84a74ad734e493d5fa711b2c6cfea75db1bedf68c713a31d62727
+
+pkgname = bareftp-legacy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cab08c2b846f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Joan Figueras <ffigue at gmail dot com>
+# Contributor: Arthur Zamarin <arthurzam@gmail.com>
+
+pkgname=bareftp-legacy
+_pkgname=bareftp
+pkgver=0.3.12
+pkgrel=1
+pkgdesc="bareFTP a file transfer client supporting the FTP, FTPS and SFTP protocols"
+arch=('i686' 'x86_64')
+url="http://www.bareftp.org/"
+license=('GPL')
+depends=('gnome-sharp>=2' 'gnome-icon-theme' 'gnome-keyring-sharp' 'mono>=2')
+makedepends=('intltool>=0.35' 'pkgconfig>=0.9')
+replaces=('bareftp')
+provides=('bareftp')
+conflicts=('bareftp')
+install=${pkgname}.install
+source=(http://www.bareftp.org/release/${_pkgname}-${pkgver}.tar.gz)
+sha256sums=('efb22c6b03a84a74ad734e493d5fa711b2c6cfea75db1bedf68c713a31d62727')
+
+prepare() {
+ # Simple patch to workaround recent mono dependency
+ sed -e 's;mono/2.0;mono/4.5;g' -i ${srcdir}/${_pkgname}-${pkgver}/configure
+}
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ export MONO_SHARED_DIR=$(pwd)
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+}
+
diff --git a/bareftp-legacy.install b/bareftp-legacy.install
new file mode 100644
index 000000000000..bbe376fb1dfb
--- /dev/null
+++ b/bareftp-legacy.install
@@ -0,0 +1,22 @@
+# Contributor: Christoph Zeiler <archNOSPAM_at_moonblade.dot.org>
+
+post_install() {
+
+ echo '###########################################################################
+IMPORTANT!
+
+This is the C#/Mono-based source for bareFTP.
+Active development has stopped on this source. Only critical bugs and
+build issues will be fixed.
+
+Active development is happening on the new python based source living at
+http://github.com/chreide/bareftp. After a first release based on the new
+source (version 0.4), this source will be totally abandoned
+###########################################################################'
+
+}
+
+post_upgrade() {
+ post_install $1
+}
+