summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
-rw-r--r--barrydesktop.desktop7
-rw-r--r--iterator-buildfix.patch27
-rw-r--r--wx3.0-compat.patch58
5 files changed, 3 insertions, 117 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2db920105b3..5f6b420eaf3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = barry
pkgdesc = Barry is an Open Source application that provides a Desktop GUI, synchronization, backup, restore and program management for BlackBerry ™ devices.
pkgver = 0.18.5
- pkgrel = 8
+ pkgrel = 9
url = https://github.com/NetDirect/barry
arch = i686
arch = x86_64
@@ -18,20 +18,14 @@ pkgbase = barry
optdepends = ppp: for tethering with pppob
options = !libtool
source = https://github.com/NetDirect/barry/archive/barry-0.18.5.tar.gz
- source = barrydesktop.desktop
source = barrybackup.desktop
source = fix-sizeof-use.patch
- source = wx3.0-compat.patch
source = c++11.patch
- source = iterator-buildfix.patch
source = libusb-rules-noplugdev.patch
sha256sums = cfe5224c34b25575543bbdeebf979074f76ccc7d37116f15aef20509e6c06c91
- sha256sums = aa97e456e0bb1f39cf0d95b1f35080d328947a3bcf40b2b97a0ab11ad34ccc21
sha256sums = 1c6ecd68977da4a3184c3e6d4bea36e4c40949d6bf7bb4ad8717aa6c19fed4fa
sha256sums = d1eb3ff669d5d8490112ceb4138fe9eb107bdbbc8621c98ead5ff47b9a7faf4e
- sha256sums = d89dec40916c99355426a9430130a34b9c9f8deccf2e0bd2be75c6eea46249f3
sha256sums = bd211b7323a36f255af7cad13b886d8bb45d74f1d2bcecef00733bb5a9080f2c
- sha256sums = 690d6d9cdd5f84ac120e5e2a0c974916217a059c25ad08dd1b45b33d858993ad
sha256sums = 2da11475bb3d5c9c94f7625b33e3ae29442413b25f320e9f70d4777180d5bd4a
pkgname = barry
diff --git a/PKGBUILD b/PKGBUILD
index e9e79c16916c..878a212f98a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=barry
pkgver=0.18.5
-pkgrel=8
+pkgrel=9
pkgdesc="Barry is an Open Source application that provides a Desktop GUI, synchronization, backup, restore and program management for BlackBerry ™ devices."
url=https://github.com/NetDirect/barry
license=('GPL')
@@ -14,20 +14,14 @@ optdepends=('fuse2: for mounting the BB database with bfuse'
'ppp: for tethering with pppob')
options=('!libtool')
source=("https://github.com/NetDirect/${pkgname}/archive/${pkgname}-${pkgver}.tar.gz"
- "barrydesktop.desktop"
"barrybackup.desktop"
"fix-sizeof-use.patch"
- "wx3.0-compat.patch"
"c++11.patch"
- "iterator-buildfix.patch"
"libusb-rules-noplugdev.patch")
sha256sums=('cfe5224c34b25575543bbdeebf979074f76ccc7d37116f15aef20509e6c06c91'
- 'aa97e456e0bb1f39cf0d95b1f35080d328947a3bcf40b2b97a0ab11ad34ccc21'
'1c6ecd68977da4a3184c3e6d4bea36e4c40949d6bf7bb4ad8717aa6c19fed4fa'
'd1eb3ff669d5d8490112ceb4138fe9eb107bdbbc8621c98ead5ff47b9a7faf4e'
- 'd89dec40916c99355426a9430130a34b9c9f8deccf2e0bd2be75c6eea46249f3'
'bd211b7323a36f255af7cad13b886d8bb45d74f1d2bcecef00733bb5a9080f2c'
- '690d6d9cdd5f84ac120e5e2a0c974916217a059c25ad08dd1b45b33d858993ad'
'2da11475bb3d5c9c94f7625b33e3ae29442413b25f320e9f70d4777180d5bd4a')
prepare() {
@@ -36,14 +30,10 @@ prepare() {
# Debian patches
patch -Np1 -i "${srcdir}/fix-sizeof-use.patch"
- patch -Np1 -i "${srcdir}/wx3.0-compat.patch"
# C++11 compatibility
patch -Np1 -i "${srcdir}/c++11.patch"
- # Fix build failure for functions that return reverse iterators
- patch -Np1 -i "${srcdir}/iterator-buildfix.patch"
-
# Don't set device group ownership to plugdev in the udev rules file as Arch
# doesn't have plugdev. Just apply read-write globally
patch -Np1 -i "${srcdir}/libusb-rules-noplugdev.patch"
@@ -57,10 +47,7 @@ build() {
export CXXFLAGS="-std=c++11"
export CPPFLAGS="-Wno-error"
- ./configure --prefix=/usr --libexec=/usr/lib --sbindir=/usr/bin \
- --enable-gui \
- --disable-desktop \
- --without-guisu
+ ./configure --prefix=/usr --libexec=/usr/lib --sbindir=/usr/bin --enable-gui
make
}
@@ -80,9 +67,6 @@ package() {
cp ./desktop/images/barry_logo_icon.xpm ${pkgdir}/usr/share/pixmaps
mkdir -p ${pkgdir}/usr/share/applications
- # We are no longer compiling barrydesktop so there's no need to install the
- # desktop entry file
- # cp ../barrydesktop.desktop ${pkgdir}/usr/share/applications
cp ../barrybackup.desktop ${pkgdir}/usr/share/applications
# Install udev rules to allow barrybackup to access devices without root
diff --git a/barrydesktop.desktop b/barrydesktop.desktop
deleted file mode 100644
index 4274a3afa665..000000000000
--- a/barrydesktop.desktop
+++ /dev/null
@@ -1,7 +0,0 @@
-[Desktop Entry]
-Name=Barry
-Comment=Synchronization, backup, restore and program management for BlackBerry ™ devices.
-Type=Application
-Exec=barrydesktop
-Icon=barry_logo_icon
-Categories=Application;Utility; \ No newline at end of file
diff --git a/iterator-buildfix.patch b/iterator-buildfix.patch
deleted file mode 100644
index 9089489db68c..000000000000
--- a/iterator-buildfix.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -Nur original/desktop/src/optout.h modified/desktop/src/optout.h
---- original/desktop/src/optout.h 2013-11-17 23:56:58.000000000 +0000
-+++ modified/desktop/src/optout.h 2018-06-18 12:11:40.870542851 +0100
-@@ -92,6 +92,8 @@
- typedef std::vector<Element*> container_type;
- typedef container_type::iterator iterator;
- typedef container_type::const_iterator const_iterator;
-+ typedef container_type::reverse_iterator reverse_iterator;
-+ typedef container_type::const_reverse_iterator const_reverse_iterator;
- typedef container_type::size_type size_type;
-
- private:
-@@ -134,10 +136,10 @@
- const_iterator begin() const { return m_con.begin(); }
- iterator end() { return m_con.end(); }
- const_iterator end() const { return m_con.end(); }
-- iterator rbegin() { return m_con.rbegin(); }
-- const_iterator rbegin() const { return m_con.rbegin(); }
-- iterator rend() { return m_con.rend(); }
-- const_iterator rend() const { return m_con.rend(); }
-+ reverse_iterator rbegin() { return m_con.rbegin(); }
-+ const_reverse_iterator rbegin() const { return m_con.rbegin(); }
-+ reverse_iterator rend() { return m_con.rend(); }
-+ const_reverse_iterator rend() const { return m_con.rend(); }
-
- // since iterators hold Element* pointers, these functions
- // are just a helpful dynamic cast aid
diff --git a/wx3.0-compat.patch b/wx3.0-compat.patch
deleted file mode 100644
index 72fd2ce2c7f5..000000000000
--- a/wx3.0-compat.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-Description: Fix to build with wxWidgets 3.0
-Author: Olly Betts <olly@survex.com>
-Last-Update: 2014-08-14
-
---- a/desktop/src/Mode.h
-+++ b/desktop/src/Mode.h
-@@ -23,6 +23,7 @@
- #define __BARRYDESKTOP_MODE_H__
-
- #include <wx/wx.h>
-+#include <wx/listctrl.h>
-
- class Mode
- {
---- a/desktop/src/bsyncjail.cc
-+++ b/desktop/src/bsyncjail.cc
-@@ -177,8 +177,8 @@
- void BarrySyncJail::HandleConflict(OpenSync::SyncConflict &conflict)
- {
- OpenSync::SyncConflict::iterator i;
-- int size = 0;
-- wxChar *buf = 0;
-+ size_t size = 0;
-+ const wxChar *buf = 0;
-
- // start with a new sequence ID
- m_sequenceID++;
-@@ -218,7 +218,7 @@
- }
-
- // then wait on the server to tell us what choice was made
-- buf = m_conflict_con->Request(CONFLICT_ITEM_ANSWER, &size);
-+ buf = (const wxChar *)m_conflict_con->Request(CONFLICT_ITEM_ANSWER, &size);
- if( buf ) {
- wxString msg(buf);
- istringstream iss(string(msg.utf8_str()));
---- a/desktop/src/MigrateDlg.cc
-+++ b/desktop/src/MigrateDlg.cc
-@@ -81,7 +81,7 @@
- wxCommandEvent event(MET_PROMPT_PASSWORD, wxID_ANY);
- event.SetEventObject(m_dlg);
- event.SetInt(bp.remaining_tries());
-- m_dlg->AddPendingEvent(event);
-+ m_dlg->GetEventHandler()->ProcessEvent(event);
- m_dlg->WaitForEvent();
-
- password_result = m_dlg->GetPassword().utf8_str();
---- a/src/probe.cc
-+++ b/src/probe.cc
-@@ -170,7 +170,7 @@
- // now dump all logged error messages
- if( auto_dump_log && m_fail_msgs.size() ) {
- eout(string_vprintf(_("Probe logged %u exception messages:"),
-- m_fail_msgs.size()));
-+ (unsigned)m_fail_msgs.size()));
- for( std::vector<std::string>::const_iterator b = m_fail_msgs.begin();
- b != m_fail_msgs.end();
- ++b )