summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71023c7e67d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = base16-shell-preview
+ pkgdesc = A tool to preview and enable Base16 Shell themes in your terminal
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/nvllsvm/base16-shell-preview
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/nvllsvm/base16-shell-preview/archive/1.0.0/base16-shell-preview-1.0.0.tar.gz
+ sha512sums = 669351fb5317bacee61f95d19a716565adca0cd842ce7ba631cb8234e9cd53c2adead48666959621836553d1733f0d788b56520feb8689bf1d5965e7b9eb3e40
+
+pkgname = base16-shell-preview
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1970994f527a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/.SRCINFO
+!/.gitignore
+!/PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f1739a0291c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Andrew Rabert <ar@nullsum.net>
+
+pkgname=base16-shell-preview
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='A tool to preview and enable Base16 Shell themes in your terminal'
+url='https://github.com/nvllsvm/base16-shell-preview'
+arch=('any')
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+source=(https://github.com/nvllsvm/base16-shell-preview/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz)
+sha512sums=('669351fb5317bacee61f95d19a716565adca0cd842ce7ba631cb8234e9cd53c2adead48666959621836553d1733f0d788b56520feb8689bf1d5965e7b9eb3e40')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ python setup.py build
+}
+
+package(){
+ cd ${pkgname}-${pkgver}
+ python setup.py install -O1 --root="${pkgdir}" --prefix=/usr --skip-build
+}