summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
-rw-r--r--bash-docs.install11
3 files changed, 23 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce40b0b3d7e6..83b0a49523ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = bash-docs
pkgdesc = Advanced Bash-Scripting Guide in HTML
pkgver = 10
- pkgrel = 1
+ pkgrel = 2
url = http://tldp.org/LDP/abs/html/
+ install = bash-docs.install
arch = any
- license = GPL
+ license = custom
options = docs
source = http://www.tldp.org/LDP/abs/abs-guide.html.tar.gz
- md5sums = 7014ea02a91ada997373fd12053b4061
+ sha256sums = e543941dc1d32689fca9da49ab89dc5f11f1655937a10afc6b3a414ac4b2da9e
pkgname = bash-docs
diff --git a/PKGBUILD b/PKGBUILD
index 2f80413bee04..72b2b0e6c260 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,23 @@
-# $Id: PKGBUILD 194152 2016-10-31 13:48:24Z spupykin $
-# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
-# Maintainer: jason ryan <jasonwryan@gmail.com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: jason ryan <jasonwryan@gmail.com>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=bash-docs
pkgver=10
-pkgrel=1
+pkgrel=2
pkgdesc="Advanced Bash-Scripting Guide in HTML"
arch=('any')
url="http://tldp.org/LDP/abs/html/"
-license=('GPL')
+license=('custom')
options=('docs')
source=("http://www.tldp.org/LDP/abs/abs-guide.html.tar.gz")
-md5sums=('7014ea02a91ada997373fd12053b4061')
+sha256sums=('e543941dc1d32689fca9da49ab89dc5f11f1655937a10afc6b3a414ac4b2da9e')
+install=$pkgname.install
package(){
cd "$srcdir/abs-guide"
install -d "$pkgdir"/usr/share/doc/bash
cp -rf * "$pkgdir"/usr/share/doc/bash
+ install -d "$pkgdir"/usr/share/licenses/$pkgname
}
diff --git a/bash-docs.install b/bash-docs.install
new file mode 100644
index 000000000000..226fe40ce574
--- /dev/null
+++ b/bash-docs.install
@@ -0,0 +1,11 @@
+post_install() {
+ ln -s /usr/share/doc/bash/copyright.html /usr/share/licenses/bash-docs/copyright.html
+}
+
+post_update() {
+ post_install
+}
+
+pre_remove() {
+ rm /usr/share/licenses/bash-docs/copyright.html
+}