summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD35
2 files changed, 45 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d3c88e0abcb..d1ed3866df0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,42 @@
pkgbase = bash-it-git
pkgdesc = A community Bash framework
- pkgver = r1
+ pkgver = r1716.64abb64
pkgrel = 1
url = https://github.com/Bash-it/bash-it
install = bash-it-git.install
arch = any
license = custom:undecided
+ makedepends = git
+ depends = bash
+ depends = coreutils
+ depends = curl
+ depends = p7zip
+ optdepends = autojump: plugin
+ optdepends = base-devel: `makefile` completion
+ optdepends = docker: plugin
+ optdepends = git: theme integration, multiple alias/completion/plugin modules
+ optdepends = hub: completion, plugin
+ optdepends = irssi: integration
+ optdepends = java-environment-common: plugin
+ optdepends = python: plugin
+ optdepends = python3: plugin, `django` completion, `proxy` plugin
+ optdepends = packer: completion
+ optdepends = ruby: theme integration, plugin
+ optdepends = ruby-bundler: alias, completion
+ optdepends = rbenv: plugin
+ optdepends = thefuck: aliases
+ optdepends = wget: `browser` plugin
+ conflicts = bash-it
+ options = libtool
+ options = staticlibs
+ options = !strip
+ source = bash-it-git::git+https://github.com/Bash-it/bash-it.git
source = LICENSE
+ source = custom.lib.bash.shim
+ source = install.sh.wrapper
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = bash-it-git
diff --git a/PKGBUILD b/PKGBUILD
index e92291c3f0b4..4cc283bc9da6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,14 @@
# PKGBUILD reference: https://wiki.archlinux.org/index.php/PKGBUILD
pkgname=bash-it-git
-pkgver=master
+pkgver=r1716.64abb64
pkgrel=1
pkgdesc='A community Bash framework'
arch=('any')
url='https://github.com/Bash-it/bash-it'
license=('custom:undecided')
depends=('bash' 'coreutils' 'curl' 'p7zip')
+makedepends=('git')
optdepends=(
'autojump: plugin'
'base-devel: `makefile` completion'
@@ -32,7 +33,7 @@ conflicts=('bash-it')
options=('libtool' 'staticlibs' '!strip')
install="${pkgname}.install"
source=(
- 'https://github.com/Bash-it/bash-it/tarball/master'
+ "${pkgname}::git+https://github.com/Bash-it/bash-it.git"
'LICENSE'
'custom.lib.bash.shim'
'install.sh.wrapper'
@@ -43,19 +44,11 @@ sha512sums=(
'SKIP'
'SKIP'
)
-noextract=("${pkgname}.tar.gz")
-prepare() {
- mv "${srcdir}/master"{,.tar.gz}
-
- tar -x \
- -f "${srcdir}/master.tar.gz" -z \
- --no-anchored --wildcards -C "${srcdir}" \
- --exclude='test' \
- --strip-components=1 \
- '.editorconfig' 'aliases' 'completion' 'custom' \
- 'lib' 'plugins' 'template' 'themes' \
- 'CONTRIBUTING.md' 'README.md' '*.sh'
+pkgver() {
+ printf "r%s.%s" \
+ "$(git -C "${pkgname}" rev-list --count HEAD)" \
+ "$(git -C "${pkgname}" rev-parse --short HEAD)"
}
package() {
@@ -70,9 +63,9 @@ package() {
"${srcdir}/LICENSE"
cp -r --preserve=mode -t "${pkgdir}/usr/lib/${pkgname}" \
- "${srcdir}"/{bash_it,install,uninstall}.sh \
- "${srcdir}"/{aliases,completion,custom,lib} \
- "${srcdir}"/{plugins,themes}
+ "${srcdir}/${pkgname}"/{bash_it,install,uninstall}.sh \
+ "${srcdir}/${pkgname}"/{aliases,completion,custom,lib} \
+ "${srcdir}/${pkgname}"/{plugins,themes}
# Copy warning shim to `lib/custom.bash`
cp --preserve=mode \
@@ -81,9 +74,9 @@ package() {
# `.editorconfig` is not meant to be user-editable
cp -r --preserve=mode -t "${pkgdir}/usr/share/${pkgname}" \
- "${srcdir}/.editorconfig" \
- "${srcdir}/install.sh" \
- "${srcdir}/template"
+ "${srcdir}/${pkgname}/.editorconfig" \
+ "${srcdir}/${pkgname}/install.sh" \
+ "${srcdir}/${pkgname}/template"
# Copy wrapper for `install.sh`
cp --preserve=mode \
@@ -91,7 +84,7 @@ package() {
"${pkgdir}/usr/share/${pkgname}/install.sh"
cp --preserve=mode -t "${pkgdir}/usr/share/doc/${pkgname}" \
- "${srcdir}"/*.md
+ "${srcdir}/${pkgname}"/*.md
# This is where things get a little tricky.
#