summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd19b21009e6..478a88c9a1bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = bcunit-git
pkgdesc = A fork of CUnit, a C unit testing framework
- pkgver = 3.0.2.r11.g966505d
+ pkgver = 3.0.2+12+g3c720fb
pkgrel = 1
url = http://www.linphone.org/
arch = x86_64
license = GPL
makedepends = cmake
makedepends = git
- provides = bcunit
+ provides = bcunit=$pkgver
conflicts = bcunit
source = git+https://gitlab.linphone.org/BC/public/bcunit.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 1f1224376ec6..4cc627f01c27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bcunit-git
_pkgname=bcunit
-pkgver=3.0.2.r11.g966505d
+pkgver=3.0.2+12+g3c720fb
pkgrel=1
pkgdesc="A fork of CUnit, a C unit testing framework"
arch=('x86_64')
@@ -10,24 +10,24 @@ url="http://www.linphone.org/"
license=('GPL')
depends=()
makedepends=('cmake' 'git')
-provides=('bcunit')
+provides=('bcunit=$pkgver')
conflicts=('bcunit')
source=("git+https://gitlab.linphone.org/BC/public/bcunit.git")
sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/; s/-/./g'
+ git describe --long --tags | sed 's/\([^-]*-g\)/\1/; s/-/+/g'
}
build() {
cd "${srcdir}"
mkdir -p build
cd build
- cmake -DCMAKE_INSTALL_LIBDIR="/usr/lib" \
- -DCMAKE_INSTALL_PREFIX="/usr" \
- -DENABLE_STATIC=NO \
- "../$_pkgname"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DENABLE_STATIC=NO \
+ "../$_pkgname"
make
}