summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--fix-makefile-kernelrelease.patch23
3 files changed, 33 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea18417b1763..af414a8d197d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Apr 26 05:31:11 UTC 2017
+# Tue Jul 18 07:48:46 UTC 2017
pkgbase = bcwc-pcie-dkms
pkgdesc = Reverse engineered Linux driver for the Broadcom 1570 PCIe webcam.
- pkgver = 0r249.758fe01
+ pkgver = 0r254.a22f248
pkgrel = 1
url = https://github.com/patjak/bcwc_pcie
install = bcwc-pcie-dkms.install
@@ -19,9 +19,11 @@ pkgbase = bcwc-pcie-dkms
source = bcwc-pcie-dkms::git+https://github.com/patjak/bcwc_pcie.git#branch=mainline
source = bcwc-pcie.modprobe.conf
source = bcwc-pcie.modules-load.conf
+ source = fix-makefile-kernelrelease.patch
md5sums = SKIP
md5sums = 7531f220d5c3dd0ab5c31c445d526d7f
md5sums = d8dc0e4e125b7887b226bda0c28f30be
+ md5sums = 24023a52752eb26145c7246e8df576d8
pkgname = bcwc-pcie-dkms
diff --git a/PKGBUILD b/PKGBUILD
index 1ca3e81eed59..55e80330a7a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
pkgname="bcwc-pcie-dkms"
-pkgver=0r249.758fe01
+pkgver=0r254.a22f248
pkgrel=1
pkgdesc="Reverse engineered Linux driver for the Broadcom 1570 PCIe webcam."
arch=('x86_64')
@@ -15,10 +15,12 @@ install="$pkgname.install"
source=("$pkgname::git+https://github.com/patjak/bcwc_pcie.git#branch=mainline"
"bcwc-pcie.modprobe.conf"
- "bcwc-pcie.modules-load.conf")
+ "bcwc-pcie.modules-load.conf"
+ "fix-makefile-kernelrelease.patch")
md5sums=('SKIP'
'7531f220d5c3dd0ab5c31c445d526d7f'
- 'd8dc0e4e125b7887b226bda0c28f30be')
+ 'd8dc0e4e125b7887b226bda0c28f30be'
+ '24023a52752eb26145c7246e8df576d8')
pkgver() {
cd "$srcdir/$pkgname"
@@ -28,9 +30,7 @@ pkgver() {
package() {
cd $srcdir/$pkgname
- # add dkms config
- git cherry-pick 76945312a9d2e786bebc9bb5711f5962365c5c20
- git cherry-pick 4901c363e8688a46b83bfcbee92c1588dca6054c
+ patch -p1 < $srcdir/fix-makefile-kernelrelease.patch
for FILE in dkms.conf Makefile *.[ch]; do
install -Dm 644 "$FILE" "$pkgdir/usr/src/${pkgname/-dkms/}-${pkgver}/$FILE"
diff --git a/fix-makefile-kernelrelease.patch b/fix-makefile-kernelrelease.patch
new file mode 100644
index 000000000000..c2f05bcc9031
--- /dev/null
+++ b/fix-makefile-kernelrelease.patch
@@ -0,0 +1,23 @@
+commit 76945312a9d2e786bebc9bb5711f5962365c5c20
+Author: Joe Barnett <jbarnett@stanfordalumni.org>
+Date: Thu Apr 21 15:57:16 2016 -0700
+
+ Add dkms.conf and tweak Makefile to work with dkms
+
+ Specifically, allow building for an installed kernel that is not the running kernel
+
+diff --git a/Makefile b/Makefile
+index 0e4b2a8..0ddf666 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,10 @@
+ facetimehd-objs := fthd_ddr.o fthd_hw.o fthd_drv.o fthd_ringbuf.o fthd_isp.o fthd_v4l2.o fthd_buffer.o fthd_debugfs.o
+ obj-m := facetimehd.o
+
++KVERSION := $(KERNELRELEASE)
++ifeq ($(origin KERNELRELEASE), undefined)
+ KVERSION := $(shell uname -r)
++endif
+ KDIR := /lib/modules/$(KVERSION)/build
+ PWD := $(shell pwd)
+