summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
-rw-r--r--wno-error.patch11
4 files changed, 40 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec5dd21be7fc..145abe4175d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,23 @@
pkgbase = beanstalkd-git
- pkgdesc = Fast, simple message queue server, git version patched to support unix sockets
- pkgver = dev1.10.r1.g86231ba
- pkgrel = 2
+ pkgdesc = Fast, simple message queue server, git version
+ pkgver = dev1.12.r11.g4c275d5
+ pkgrel = 1
+ url = https://beanstalkd.github.io/
arch = i686
arch = x86_64
license = GPL
provides = beanstalkd
conflicts = beanstalkd
backup = etc/conf.d/beanstalkd
- source = git://github.com/kr/beanstalkd.git
- source = unix_sockets.patch::https://patch-diff.githubusercontent.com/raw/kr/beanstalkd/pull/150.patch
+ source = git+http://github.com/kr/beanstalkd.git
source = beanstalkd@.service
source = beanstalkd.service
source = beanstalkd.conf
- md5sums = SKIP
- md5sums = c17cd694afab67d2d72055f3184c7335
- md5sums = f6151d5d2f07c24977cafba38a9e67c9
- md5sums = d05b907abfb19174a7321676ecc0c819
- md5sums = 7fdc2e3d1dc9c6559b7b007b74588a09
+ source = wno-error.patch
+ sha1sums = SKIP
+ sha1sums = 8ef8fe89b7da43ed92ae7b2428f1126a5a0d060a
+ sha1sums = 3ba17f1786aeabcba7e11c5a42415a7882c67c1b
+ sha1sums = 96f94770b132a0c26acddeab224c64bb5bed359a
+ sha1sums = 4098dfbbc0639c4c772b0e53a17fb175bc7f4086
pkgname = beanstalkd-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7546db839754
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.*
+beanstalkd
+pkg/
+src/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 50617b46021b..15fc8a8f4487 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,28 @@
pkgname=beanstalkd-git
-pkgver=dev1.10.r1.g86231ba
+pkgver=dev1.12.r11.g4c275d5
-pkgrel=2
+pkgrel=1
epoch=
-pkgdesc="Fast, simple message queue server, git version patched to support unix sockets"
+pkgdesc="Fast, simple message queue server, git version"
arch=('i686' 'x86_64')
-url=""
+url="https://beanstalkd.github.io/"
license=('GPL')
depends=()
makedepends=()
conflicts=('beanstalkd')
provides=('beanstalkd')
backup=('etc/conf.d/beanstalkd')
-options=()
-install=
-changelog=
-source=("git://github.com/kr/beanstalkd.git"
- "unix_sockets.patch::https://patch-diff.githubusercontent.com/raw/kr/beanstalkd/pull/150.patch"
+source=("git+http://github.com/kr/beanstalkd.git"
"beanstalkd@.service"
"beanstalkd.service"
- "beanstalkd.conf")
-md5sums=('SKIP'
- 'c17cd694afab67d2d72055f3184c7335'
- 'f6151d5d2f07c24977cafba38a9e67c9'
- 'd05b907abfb19174a7321676ecc0c819'
- '7fdc2e3d1dc9c6559b7b007b74588a09')
+ "beanstalkd.conf"
+ "wno-error.patch")
+sha1sums=('SKIP'
+ '8ef8fe89b7da43ed92ae7b2428f1126a5a0d060a'
+ '3ba17f1786aeabcba7e11c5a42415a7882c67c1b'
+ '96f94770b132a0c26acddeab224c64bb5bed359a'
+ '4098dfbbc0639c4c772b0e53a17fb175bc7f4086')
+
pkgver() {
cd "$srcdir/beanstalkd"
@@ -35,7 +33,7 @@ pkgver() {
prepare() {
cd "$srcdir/beanstalkd"
- patch -p1 < $srcdir/unix_sockets.patch
+ patch -p0 < $srcdir/wno-error.patch
}
build() {
diff --git a/wno-error.patch b/wno-error.patch
new file mode 100644
index 000000000000..7b2c46613683
--- /dev/null
+++ b/wno-error.patch
@@ -0,0 +1,11 @@
+--- Makefile.old 2019-07-02 17:04:51.306084390 -0400
++++ Makefile 2019-07-02 17:04:31.976016845 -0400
+@@ -1,7 +1,7 @@
+ PREFIX=/usr/local
+ BINDIR=$(DESTDIR)$(PREFIX)/bin
+
+-override CFLAGS+=-Wall -Werror -Wformat=2 -g
++override CFLAGS+=-Wall -Wno-error -Wformat=2 -g
+ override LDFLAGS?=
+
+ OS=$(shell uname|tr A-Z a-z)