summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD35
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..923f4b27f0d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = beatbuddy-hib
+ pkgdesc = A hand-drawn arcade game with unique music interaction.
+ pkgver = 1396630212
+ pkgrel = 1
+ url = http://www.threaks.com/
+ arch = i686
+ arch = x86_64
+ license = custom:commercial
+ source = hib://BeatbuddyLinux_1396630212.zip
+ sha512sums = 55bb2781a3971fcf55c8361f4bf0e9829e27e59241604773b2e6275bcc502cd82702bb2e818bba29567ce4c0cc1578ba4a85f817282767598884471d30c2175c
+
+pkgname = beatbuddy-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d06936e065c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+#Maintainer: Philip Abernethy<chais.z3r0@gmail.com>
+pkgname=beatbuddy-hib
+pkgver=1396630212
+pkgrel=1
+pkgdesc="A hand-drawn arcade game with unique music interaction."
+url="http://www.threaks.com/"
+arch=('i686' 'x86_64')
+license=('custom:commercial')
+
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+source=("hib://BeatbuddyLinux_${pkgver}.zip")
+
+sha512sums=('55bb2781a3971fcf55c8361f4bf0e9829e27e59241604773b2e6275bcc502cd82702bb2e818bba29567ce4c0cc1578ba4a85f817282767598884471d30c2175c')
+
+PKGEXT=".pkg.tar"
+
+package() {
+ mkdir -p "$pkgdir"/{opt,usr/{bin,share/applications}}
+ mv Beatbuddy "$pkgdir"/opt/beatbuddy
+ chmod a+x "$pkgdir"/opt/beatbuddy/Beatbuddy.x86
+ echo '#!/bin/bash
+cd /opt/beatbuddy
+./Beatbuddy.x86' > "$pkgdir"/usr/bin/beatbuddy
+ chmod a+x "$pkgdir"/usr/bin/beatbuddy
+ echo "[Desktop Entry]
+Type=Application
+Name=Beatbuddy
+GenericName=Beatbuddy
+Comment=$pkgdesc
+Icon=/opt/beatbuddy/Beatbuddy_Data/Resources/UnityPlayer.png
+Exec=/usr/bin/beatbuddy
+Categories=Game;
+Path=/opt/beatbuddy" > "$pkgdir"/usr/share/applications/beatbuddy.desktop
+}