summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44763399d04b..26175d8bfb10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = birdtray-git
pkgdesc = Run Thunderbird with a system tray icon.
pkgver = latest
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/gyunaev/birdtray
arch = i686
arch = x86_64
@@ -14,6 +14,7 @@ pkgbase = birdtray-git
makedepends = qt5-tools
depends = qt5-svg
depends = qt5-x11extras
+ optdepends = qt5-translations: Support for translations
provides = birdtray
conflicts = birdtray
source = git+https://github.com/gyunaev/birdtray.git
diff --git a/PKGBUILD b/PKGBUILD
index 66fda977aa5c..cf4592537913 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,13 @@
_pkgbase=birdtray
pkgname=$_pkgbase-git
pkgver=latest
-pkgrel=4
+pkgrel=5
pkgdesc="Run Thunderbird with a system tray icon."
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url="https://github.com/gyunaev/birdtray"
license=('GPL-3.0')
depends=(qt5-svg qt5-x11extras)
+optdepends=('qt5-translations: Support for translations')
makedepends=(cmake git qt5-tools)
conflicts=($_pkgbase)
provides=($_pkgbase)
@@ -30,7 +31,6 @@ build() {
}
package() {
- cd build
- make DESTDIR="$pkgdir" install
- install -Dm644 ../$_pkgbase/README.md -t"$pkgdir/usr/share/doc/$_pkgbase/"
+ make -C build DESTDIR="$pkgdir" install
+ install -Dm644 -t "$pkgdir/usr/share/doc/$_pkgbase/" $_pkgbase/README.md
}