summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6328a2d1f6c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = biscuit-kms
+ pkgdesc = simple key-value store for your infrastructure secrets.
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = https://github.com/dcoker/biscuit.git
+ arch = x86_64
+ license = Apache
+ makedepends = go
+ makedepends = gox
+ makedepends = tar
+ source = https://github.com/dcoker/biscuit/releases/download/v0.1.4/biscuit_0.1.4_Linux-64bit.tar.gz
+ sha256sums = a116620ec37548c0204b32dbfd98810a910d01e80b2cc448dac58e4f413161ad
+
+pkgname = biscuit-kms
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7f9361665ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Alessio Biancone <alebian1996@gmail.com>
+pkgname=biscuit-kms
+pkgver=0.1.4
+pkgrel=1
+pkgdesc="simple key-value store for your infrastructure secrets."
+arch=('x86_64')
+url="https://github.com/dcoker/biscuit.git"
+license=('Apache')
+makedepends=('go' 'gox' 'tar')
+source=("https://github.com/dcoker/biscuit/releases/download/v${pkgver}/biscuit_${pkgver}_Linux-64bit.tar.gz")
+sha256sums=('a116620ec37548c0204b32dbfd98810a910d01e80b2cc448dac58e4f413161ad')
+
+package() {
+ tar -xvzf "biscuit_${pkgver}_Linux-64bit.tar.gz"
+
+ install -D -m755 "biscuit" "${pkgdir}/usr/bin/biscuit"
+}