summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--qt.patch32
3 files changed, 27 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e50f05e83a83..ee491ca61a8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bitcoin-abc-qt
pkgdesc = Bitcoin ABC with bitcoind, bitcoin-cli, bitcoin-tx, and bitcoin-qt
pkgver = 0.18.3
- pkgrel = 3
+ pkgrel = 4
url = https://bitcoinabc.org
install = bitcoin.install
arch = i686
@@ -41,7 +41,7 @@ pkgbase = bitcoin-abc-qt
sha256sums = 9643eed2c20d78a9c7347df64099765773615f79d3b8a95693d871c933516880
sha256sums = 35ff9331d7df8b90adfc7d82752cca4f8b7ff23a29e5d10b07e4e3fc78050679
sha256sums = 6db7458a85a0b469ab95ad78e431d0a5db078d8809a5f4340ee040f304a9dc0d
- sha256sums = 066694fb0eb9835ee37fab70aa6941b0a8b0ed6fecba8219ab7352abcc777660
+ sha256sums = e905bc9f5d13d45b494a407a9a85a01a583818ddc01860cfe99ec9abe6f949c3
pkgname = bitcoin-abc-qt
diff --git a/PKGBUILD b/PKGBUILD
index 456c54fe4fe9..2288a907fb56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bitcoin-abc-qt
pkgver=0.18.3
-pkgrel=3
+pkgrel=4
pkgdesc="Bitcoin ABC with bitcoind, bitcoin-cli, bitcoin-tx, and bitcoin-qt"
arch=('i686' 'x86_64')
url="https://bitcoinabc.org"
@@ -22,7 +22,7 @@ sha256sums=('48db5fd2bdf2a7a719d5dec90187bcfae1becf00d808ccb895063a68344b652a'
'9643eed2c20d78a9c7347df64099765773615f79d3b8a95693d871c933516880'
'35ff9331d7df8b90adfc7d82752cca4f8b7ff23a29e5d10b07e4e3fc78050679'
'6db7458a85a0b469ab95ad78e431d0a5db078d8809a5f4340ee040f304a9dc0d'
- '066694fb0eb9835ee37fab70aa6941b0a8b0ed6fecba8219ab7352abcc777660')
+ 'd201f40404fbf4370329d19d9f0f4431b1872a5c761ac38a41f555841bc9a0eb')
backup=('etc/bitcoin/bitcoin.conf'
'etc/logrotate.d/bitcoin')
provides=('bitcoin-cli' 'bitcoin-daemon' 'bitcoin-tx' 'bitcoin-qt')
diff --git a/qt.patch b/qt.patch
index b39e9a2307e0..3aff69a51c40 100644
--- a/qt.patch
+++ b/qt.patch
@@ -1,12 +1,26 @@
diff --git a/src/qt/bitcoin.cpp b/src/qt/bitcoin.cpp
-index 985ea969c..6a62e7a90 100644
+index d3ec67e4418b..edb6e9bc8173 100644
--- a/src/qt/bitcoin.cpp
+++ b/src/qt/bitcoin.cpp
-@@ -604,6 +604,7 @@ int main(int argc, char *argv[]) {
- #if QT_VERSION >= 0x050500
- // Because of the POODLE attack it is recommended to disable SSLv3
- // (https://disablessl3.com/), so set SSL protocols to TLS1.0+.
-+ QSslSocket::sslLibraryVersionString();
- QSslConfiguration sslconf = QSslConfiguration::defaultConfiguration();
- sslconf.setProtocol(QSsl::TlsV1_0OrLater);
- QSslConfiguration::setDefaultConfiguration(sslconf);
+@@ -49,7 +49,6 @@
+ #include <QLocale>
+ #include <QMessageBox>
+ #include <QSettings>
+-#include <QSslConfiguration>
+ #include <QStringList>
+ #include <QThread>
+ #include <QTimer>
+@@ -608,13 +608,6 @@ int main(int argc, char *argv[])
+ #ifdef Q_OS_MAC
+ QApplication::setAttribute(Qt::AA_DontShowIconsInMenus);
+ #endif
+-#if QT_VERSION >= 0x050500
+- // Because of the POODLE attack it is recommended to disable SSLv3
+- // (https://disablessl3.com/), so set SSL protocols to TLS1.0+.
+- QSslConfiguration sslconf = QSslConfiguration::defaultConfiguration();
+- sslconf.setProtocol(QSsl::TlsV1_0OrLater);
+- QSslConfiguration::setDefaultConfiguration(sslconf);
+-#endif
+
+ // Register meta types used for QMetaObject::invokeMethod
+ qRegisterMetaType<bool *>();