summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 14 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2258a92fcdd9..a1a24587e7d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,14 @@
pkgbase = bitcomet
- pkgdesc = A free BitTorrent download client! Powerful, super-fast and easy-to-use
- pkgver = 2.7.0
+ pkgdesc = A BitTorrent/HTTP/FTP download client
+ pkgver = 2.8.1
pkgrel = 1
url = https://www.bitcomet.com
arch = x86_64
license = LicenseRef-bitcomet
- makedepends = appimagetool-bin
- depends = glibc
- depends = hicolor-icon-theme
- depends = zlib
- depends = lerc
- depends = fuse2
depends = webkit2gtk
- depends = libjpeg6-turbo
- options = !strip
- source = BitComet-2.7.0-x86_64.AppImage::https://download.bitcomet.com/linux/BitComet-2.7.0-x86_64.AppImage
- source = libtiff-4.5.0-4-x86_64.pkg.tar.zst::https://archive.archlinux.org/packages/l/libtiff/libtiff-4.5.0-4-x86_64.pkg.tar.zst
+ source = BitComet-2.8.1-x86_64.deb::https://download.bitcomet.com/linux/x86_64/BitComet-2.8.1-x86_64.deb
source = LICENSE.html::https://www.bitcomet.com/en/license
- sha256sums = 125e50545668c5d2204aa38b31dd1f070b8dfdf595e15bcf41de6dedc85d42f7
- sha256sums = c5eaf83c66d97b751c6e63a7b1f54378e3232e41d81505a6576ccd8741f675b9
+ sha256sums = 747a34b098be10f2f4741bef83703738c1cce8c077ff8f671cce791a41bcfe5d
sha256sums = SKIP
pkgname = bitcomet
diff --git a/PKGBUILD b/PKGBUILD
index 33fc402f2e81..8bfcf07e7c5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,30 @@
# Maintainer: irmluity <45vw4yz8g@mozmail.com>
+# Maintainer: d6k283tix <d6k283tix@mozmail.com>
pkgname=bitcomet
-pkgver=2.7.0
+pkgver=2.8.1
pkgrel=1
-pkgdesc="A free BitTorrent download client! Powerful, super-fast and easy-to-use"
+pkgdesc="A BitTorrent/HTTP/FTP download client"
arch=(x86_64)
url='https://www.bitcomet.com'
license=('LicenseRef-bitcomet')
-depends=('glibc' 'hicolor-icon-theme' 'zlib' 'lerc' 'fuse2' 'webkit2gtk' 'libjpeg6-turbo')
-makedepends=('appimagetool-bin')
-options=(!strip)
+depends=('webkit2gtk')
source=(
- "BitComet-${pkgver}-${CARCH}.AppImage::https://download.bitcomet.com/linux/BitComet-${pkgver}-${CARCH}.AppImage"
- "libtiff-4.5.0-4-x86_64.pkg.tar.zst::https://archive.archlinux.org/packages/l/libtiff/libtiff-4.5.0-4-${CARCH}.pkg.tar.zst"
+ "BitComet-${pkgver}-${CARCH}.deb::https://download.bitcomet.com/linux/x86_64/BitComet-2.8.1-x86_64.deb"
"LICENSE.html::https://www.bitcomet.com/en/license"
)
sha256sums=(
- "125e50545668c5d2204aa38b31dd1f070b8dfdf595e15bcf41de6dedc85d42f7"
- "c5eaf83c66d97b751c6e63a7b1f54378e3232e41d81505a6576ccd8741f675b9"
+ "747a34b098be10f2f4741bef83703738c1cce8c077ff8f671cce791a41bcfe5d"
"SKIP"
)
-_install_path="/opt/$pkgname"
prepare() {
- cd "${srcdir}"
- chmod a+x "BitComet-${pkgver}-${CARCH}.AppImage"
- ./BitComet-${pkgver}-${CARCH}.AppImage --appimage-extract >/dev/null
+ cd $srcdir
+ tar -xf data.tar.xz
}
package() {
- install -Dm755 "${srcdir}/usr/lib/libtiff.so.6.0.0" "${srcdir}/squashfs-root/lib/${CARCH}-linux-gnu/libtiff.so.6"
- install -Dm755 "${srcdir}/usr/lib/libtiffxx.so.6.0.0" "${srcdir}/squashfs-root/lib/${CARCH}-linux-gnu/libtiffxx.so.6"
- unset SOURCE_DATE_EPOCH
- ARCH=${CARCH} appimagetool "${srcdir}/squashfs-root" "${srcdir}/${pkgname}.AppImage"
- install -Dm755 "${srcdir}/${pkgname}.AppImage" "${pkgdir}/${_install_path}/${pkgname}.AppImage"
- sed -i 's|Exec=usr/bin/BitComet|Exec=/usr/bin/bitcomet|g' "${srcdir}/squashfs-root/com.bitcomet.linux.desktop"
- install -Dm644 "${srcdir}/squashfs-root/com.bitcomet.linux.desktop" "$pkgdir/usr/share/applications/${pkgname}.desktop"
- install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/512x512/apps/${pkgname}.png" "${pkgdir}/usr/share/icons/hicolor/512x512/apps/${pkgname}.png"
- install -dm755 "${pkgdir}/usr/bin"
- ln -s "/opt/${pkgname}/${pkgname}.AppImage" "${pkgdir}/usr/bin/${pkgname}"
+ install -d $pkgdir/usr
+ cp -r $srcdir/usr/ $pkgdir/
install -Dm644 "$srcdir/LICENSE.html" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.html"
}