summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD34
-rw-r--r--bitfighter.install11
3 files changed, 16 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27382dfa02ee..a3dbfde3db41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,21 @@
pkgbase = bitfighter
pkgdesc = A fast-paced team-based outer-space multi-player combat game
- pkgver = 0.19g
- pkgrel = 2
+ pkgver = 019g
+ pkgrel = 3
url = http://bitfighter.org/
- install = bitfighter.install
arch = i686
arch = x86_64
license = GPL
makedepends = cmake>=3.1.0
makedepends = gcc
makedepends = glu
+ depends = sqlite
depends = sdl2
- depends = zlib
depends = libpng
depends = openal
depends = libvorbis
depends = libmodplug
depends = speex
- depends = mpg123
- depends = boost
source = http://bitfighter.org/files/bitfighter-019g.tar.gz
source = http://bitfighter.org/files/classic_level_pack.zip
source = bitfighter.png
diff --git a/PKGBUILD b/PKGBUILD
index e16f97d65f10..ca863b4850fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Szymon Scholz < szymonscholz at gmail dot com >
+# Maintainer: Naleo Hyde <naleo dot hyde at gmail dot com>
+# Contributor: Szymon Scholz < szymonscholz at gmail dot com >
# Contributor: Frederic Bezies < fredbezies at gmail dot com>
# Contributor: Larry Hajali <larryhaja[at]gmail[dot]com>
# Contributor: carstene1ns <arch carsten-teibes de>
@@ -6,47 +7,38 @@
# Contributor: archtux <antonio.arias99999 at gmail.com>
pkgname=bitfighter
-pkgver=0.19g
-pkgrel=2
+pkgver=019g
+pkgrel=3
pkgdesc="A fast-paced team-based outer-space multi-player combat game"
arch=('i686' 'x86_64')
url="http://bitfighter.org/"
license=('GPL')
depends=(
+ 'sqlite'
'sdl2'
- 'zlib'
'libpng'
'openal'
'libvorbis'
'libmodplug'
'speex'
- 'mpg123'
- 'boost'
)
makedepends=(
'cmake>=3.1.0'
'gcc'
'glu'
)
-install=${pkgname}.install
source=("http://${pkgname}.org/files/${pkgname}-${pkgver/./}.tar.gz"
"http://bitfighter.org/files/classic_level_pack.zip"
"$pkgname.png"
"$pkgname.desktop")
-
build() {
- cd ${pkgname}-${pkgver/./}/build
- cmake \
- -DCMAKE_INSTALL_PREFIX:PATH="/usr" \
- -DOPENGLES_INCLUDE_DIR="/usr/lib" \
- -DOPENGLES_LIBRARY="/usr/lib" \
- -DUSE_SDL2:BOOL=YES \
- -DMASTER_MINIMAL=YES \
- -DCMAKE_BUILD_TYPE=Release \
- -DLUAJIT_BUILTIN=YES\
- ..
-
- make VERBOSE=1
+ export CFLAGS+=" ${CPPFLAGS}"
+ export CXXFLAGS+=" ${CPPFLAGS}"
+ cmake -B build -S "bitfighter-${pkgver}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ make -C build
}
package() {
@@ -55,7 +47,7 @@ package() {
# install game ressources and executable
install -d "$pkgdir"/usr/share/$pkgname "$pkgdir"/usr/bin
cp "${srcdir}"/classic_level_pack/* resource/levels
- cp -r resource/* exe/* "$pkgdir"/usr/share/$pkgname
+ cp -r resource/* "$pkgdir"/usr/share/$pkgname
install -m755 exe/$pkgname "$pkgdir"/usr/bin/$pkgname
# install a desktop entry
diff --git a/bitfighter.install b/bitfighter.install
deleted file mode 100644
index 5e5cfef4d9f6..000000000000
--- a/bitfighter.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- update-desktop-database -q
-}