summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6624b43f1161..44112e2083a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -45,7 +45,12 @@ build() {
check() {
cd "$srcdir/$_sourcedirectory/"
+
+ # Run tests
go test -v './...'
+
+ # Verify that the basic functionality works
+ "$srcdir/$_bindir/$_pkgname" help 2>&1 | tee '/dev/stderr' | grep -q 'fetch the latest data from the server$'
}
package() {