summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD41
3 files changed, 31 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d1877f7f341..4d94d2746756 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,12 @@
-# Generated by mksrcinfo v8
-# Thu Jan 4 08:45:16 UTC 2018
pkgbase = blacksheepwall
pkgdesc = A hostname reconnaissance tool
pkgver = 3.3.0
- pkgrel = 1
- url = https://github.com/tomsteele/blacksheepwall/
+ pkgrel = 2
+ url = https://github.com/tomsteele/blacksheepwall
arch = x86_64
license = MIT
makedepends = go
- options = !strip
- options = !emptydirs
- source = https://github.com/tomsteele/blacksheepwall/archive/v3.3.0.tar.gz
- sha256sums = 201de98289060a15ef15a8f4f087be2e11a5585a8b7c7a764794624fa170a07f
+ source = blacksheepwall-3.3.0::https://github.com/tomsteele/blacksheepwall/archive/v3.3.0.tar.gz
+ sha512sums = 29dcd50ccaa1edd3e57f5b5d30d0f6372e517261efa6b5633931e786b791d5f99714a7506a969a9a64fea66a35ca790bc642cc66453c01ae5a36762d072a492b
pkgname = blacksheepwall
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index e639fc362051..e7e55b16b51b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,36 @@
-# Maintainer: Simon Legner <Simon.Legner@gmail.com>
-
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Simon Legner <Simon.Legner@gmail.com>
pkgname=blacksheepwall
pkgver=3.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="A hostname reconnaissance tool"
arch=('x86_64')
-url="https://github.com/tomsteele/$pkgname/"
-license=('MIT')
-makedepends=('go')
-options=('!strip' '!emptydirs')
-source=("https://github.com/tomsteele/$pkgname/archive/v$pkgver.tar.gz")
+url="https://github.com/tomsteele/${pkgname}"
+license=(MIT)
+makedepends=(go)
+source=(${pkgname}-${pkgver}::${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('29dcd50ccaa1edd3e57f5b5d30d0f6372e517261efa6b5633931e786b791d5f99714a7506a969a9a64fea66a35ca790bc642cc66453c01ae5a36762d072a492b')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ go mod init "${url#https://}"
+ go mod tidy
+}
build() {
- cd "$pkgname-$pkgver"
- go build
+ cd "${pkgname}-${pkgver}"
+
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ go build -o ${pkgname} .
}
package() {
- cd "$pkgname-$pkgver"
- install -Dm755 "$pkgname-$pkgver" "$pkgdir/usr/bin/$pkgname"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
-sha256sums=('201de98289060a15ef15a8f4f087be2e11a5585a8b7c7a764794624fa170a07f')