summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD43
-rw-r--r--blackvoxel.install11
-rw-r--r--blackvoxel.patch11
4 files changed, 23 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8857d19e7f7c..87d82a89308e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
pkgbase = blackvoxel
pkgdesc = Game of automation and programming in a voxel world
- pkgver = 2.31
- pkgrel = 2
- url = http://www.blackvoxel.com/
- install = blackvoxel.install
+ pkgver = 2.5
+ pkgrel = 1
+ url = https://www.blackvoxel.com/
arch = x86_64
license = GPL3
depends = glew
depends = hicolor-icon-theme
depends = mesa
depends = sdl
- source = blackvoxel_source_2_31.tar.bz2::http://www.blackvoxel.com//dm_download.php?file=139&key=1
- source = blackvoxel.patch
- sha256sums = 09d14326031cc81848c59f1c8cf9b53c91c0d36777fb58367c9fb3784f3dd1b4
- sha256sums = 5423a426434498480abe47a18ef10a11d8ee99fca8d2d05aec070814ccd6628a
+ source = blackvoxel-2.5.tar.bz2::https://www.blackvoxel.com//dm_download.php?file=170&key=1
+ sha256sums = 357fc6f4be66401b52fbbf3db8ab7b4293a3e7b3332a01f99c990d1ec36c6996
pkgname = blackvoxel
-
diff --git a/PKGBUILD b/PKGBUILD
index 879ccef93ff7..03e5be7b8841 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,32 @@
-# Maintainer: Sebastien Duthil <duthils@free.fr>
-
-# Note: I can't test on x86, feel free to drop me an email/comment with the
-# working PKGBUILD for x86
+# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
+# Contributor: Sebastien Duthil <duthils@free.fr>
pkgname=blackvoxel
-pkgver=2.31
-pkgrel=2
+pkgver=2.5
+pkgrel=1
pkgdesc="Game of automation and programming in a voxel world"
arch=('x86_64')
-url='http://www.blackvoxel.com/'
+url='https://www.blackvoxel.com/'
license=('GPL3')
depends=('glew' 'hicolor-icon-theme' 'mesa' 'sdl')
-install="${pkgname}.install"
-source=("${pkgname}_source_2_31.tar.bz2::${url}/dm_download.php?file=139&key=1"
- "blackvoxel.patch")
-sha256sums=('09d14326031cc81848c59f1c8cf9b53c91c0d36777fb58367c9fb3784f3dd1b4'
- '5423a426434498480abe47a18ef10a11d8ee99fca8d2d05aec070814ccd6628a')
+_srcdir="${pkgname}_source_2_50"
+source=("${pkgname}-${pkgver}.tar.bz2::${url}/dm_download.php?file=170&key=1")
+sha256sums=('357fc6f4be66401b52fbbf3db8ab7b4293a3e7b3332a01f99c990d1ec36c6996')
-prepare() {
- # Disable #include glext. Should be already included by glew.
- patch "${srcdir}/${pkgname}_source_2_31/src/main.cpp" "${srcdir}/blackvoxel.patch"
-}
+_datadir="/usr/share/games/${pkgname}"
build() {
- cd "${srcdir}/${pkgname}_source_2_31"
- make blackvoxeldatadir="/usr/share/${pkgname}/"
+ cd "${_srcdir}"
+ make BV_DATA_LOCATION_DIR="${_datadir}" installable
}
package() {
- cd "${srcdir}/${pkgname}_source_2_31"
+ cd "${_srcdir}"
make install \
- specialinstall=true \
- DESTDIR="${pkgdir}/" \
- bindir="usr/bin/" \
- blackvoxeldatadir="usr/share/${pkgname}/" \
- icondir2="usr/share/icons/" \
- desktopdir="usr/share/applications/"
+ doinstall=true \
+ DESTDIR="${pkgdir}" \
+ BV_DATA_INSTALL_DIR="${_datadir}" \
+ BV_BINARY_INSTALL_DIR='/usr/bin' \
+ icondir2='/usr/share/icons/' \
+ desktopdir='/usr/share/applications/'
}
diff --git a/blackvoxel.install b/blackvoxel.install
deleted file mode 100644
index 5be14e68d10a..000000000000
--- a/blackvoxel.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install () {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-}
-
-post_upgrade () {
- post_install
-}
-
-post_remove() {
- post_install
-}
diff --git a/blackvoxel.patch b/blackvoxel.patch
deleted file mode 100644
index eb58d8b64cea..000000000000
--- a/blackvoxel.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/main.cpp 2019-02-03 22:27:48.869873390 -0500
-+++ src/main.cpp 2019-02-03 22:27:56.200051727 -0500
-@@ -25,7 +25,7 @@
- #else
- # include <GL/glew.h>
- // # include <GL/gl.h>
--# include <GL/glext.h>
-+// # include <GL/glext.h>
- // # include <GL/glut.h>
- #endif
- #include "SDL/SDL.h"