summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD66
3 files changed, 30 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90c97801d963..ae0da4d58411 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,22 @@
+# Generated by mksrcinfo v8
+# Fri Feb 24 10:24:48 UTC 2017
pkgbase = blasr-git
pkgdesc = The PacBio long read aligner
- pkgver = r122.9593a09
+ pkgver = r507.f8bfa9c
pkgrel = 1
url = https://github.com/PacificBiosciences/blasr
arch = i686
arch = x86_64
license = custom
- makedepends = python2
+ makedepends = cmake
depends = hdf5-cpp-fortran
provides = blasr
conflicts = blasr
- source = blasr-git::git+https://github.com/PacificBiosciences/blasr
+ source = git+https://github.com/PacificBiosciences/blasr
+ source = git+https://github.com/PacificBiosciences/blasr_libcpp
+ source = git+https://github.com/PacificBiosciences/pbbam
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
pkgname = blasr-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..42ab3cf03f2d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.pkg.tar*
diff --git a/PKGBUILD b/PKGBUILD
index c55ab54fa585..6c63dfff67e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,83 +1,57 @@
# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
pkgname=blasr-git
-pkgver=r122.9593a09
+pkgver=r507.f8bfa9c
pkgrel=1
pkgdesc="The PacBio long read aligner"
arch=('i686' 'x86_64')
url="https://github.com/PacificBiosciences/blasr"
license=('custom')
depends=('hdf5-cpp-fortran')
-makedepends=('python2')
+makedepends=('cmake')
conflicts=('blasr')
provides=('blasr')
-source=("$pkgname::git+https://github.com/PacificBiosciences/blasr")
+source=("git+https://github.com/PacificBiosciences/blasr"
+ "git+https://github.com/PacificBiosciences/blasr_libcpp"
+ "git+https://github.com/PacificBiosciences/pbbam")
-md5sums=('SKIP')
+md5sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
- cd $srcdir/$pkgname
+ cd $srcdir/blasr
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd $srcdir/$pkgname
+ cd $srcdir/blasr
git submodule init
- git submodule update
- sed -e 's|^#!/usr/bin/env python$|#!/usr/bin/env python2|' \
- -i configure.py \
- libcpp/configure.py
+ git config submodule.libcpp.url $srcdir/blasr_libcpp
+ git config submodule.pbbam.url $srcdir/pbbam
- # we want to link against shared libs
- sed -e 's|LDFLAGS := $(LDFLAGS1) $(HDF5_LIB)/libhdf5_cpp.a $(HDF5_LIB)/libhdf5.a -lpthread -lz -ldl|LDFLAGS += $(LDFLAGS1) -lhdf5_cpp -lhdf5 -lpthread -lz -ldl|' \
- -i libcpp/unittest/normal.defines.mk \
- libcpp/unittest/common.mk
+ git submodule update
- sed -e 's|DEP_LIBS += ${LIBPBDATA_LIB} ${HDF5_LIB} ${PBBAM_LIB} ${HTSLIB_LIB} ${ZLIB_LIB}|DEP_LIBS += ${LIBPBDATA_LIB} ${PBBAM_LIB} ${HTSLIB_LIB} ${ZLIB_LIB}|' \
- -i libcpp/alignment/makefile \
- libcpp/hdf/makefile
+ mkdir -p build
}
build() {
- cd $srcdir/$pkgname
-
- export NOPBBAM=
- export HDF5_INCLUDE=/usr/include
- export HDF5_LIB=/usr/lib
+ cd $srcdir/blasr/build
- cd libcpp
-
- ./configure.py \
- --no-pbbam \
- --submodules \
- --shared
-
- make
-
- cd ..
-
- ./configure.py \
- --no-pbbam \
- --submodules \
- --shared
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ ..
make
}
package() {
- cd $srcdir/$pkgname
-
- for file in blasr utils/loadPulses utils/pls2fasta utils/samFilter utils/samtoh5 utils/samtom4 utils/sawriter utils/sdpMatcher utils/toAfg ; do
- install -Dm755 $file $pkgdir/usr/bin/$(basename $file)
- done
+ cd $srcdir/blasr/build
- for file in libcpp/pbdata/libpbdata.so libcpp/hdf/libpbihdf.so libcpp/alignment/libblasr.so ; do
- install -Dm755 $file $pkgdir/usr/lib/$(basename $file)
- done
+ make DESTDIR=$pkgdir install
- install -Dm644 LICENSES.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 ../LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}