summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 25 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 373deaf0e976..c38989705a8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
-pkgbase = boilr
+pkgbase = boilr-git
pkgdesc = A CLI tool for creating and using templates for common actions
- pkgver = 0.4.5
+ pkgver = 0.4.5.r16.g5c29306
pkgrel = 1
- url = https://github.com/Ilyes512/boilr
+ url = https://github.com/timsolov/boilr
arch = i686
arch = x86_64
arch = armv7h
arch = aarch64
license = Apache
makedepends = go
- source = https://github.com/Ilyes512/boilr/archive/0.4.5.tar.gz
- sha512sums = fde934c2fab5ad06b1f02abb43423ffeb780cf1002a7348d08bf6d59a84cb4d7e460efa8cbe2261662e4d55cecb6fb396b36e1060afb9eda2568f2f1ad20d543
-
-pkgname = boilr
+ provides = boilr
+ conflicts = boilr
+ source = git+https://github.com/timsolov/boilr.git
+ sha512sums = SKIP
+pkgname = boilr-git
diff --git a/PKGBUILD b/PKGBUILD
index 0beca0db1756..56ebe0490975 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,31 @@
# Maintainer: Markus Richter <mqus at disroot dot org>
-
-pkgname=boilr
-pkgver=0.4.5
+_pkgbase=boilr
+pkgname="$_pkgbase"-git
+pkgver=0.4.5.r16.g5c29306
pkgrel=1
pkgdesc="A CLI tool for creating and using templates for common actions"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
-url="https://github.com/Ilyes512/boilr"
+url="https://github.com/timsolov/boilr"
license=('Apache')
depends=()
optdepends=()
makedepends=('go')
-source=("https://github.com/Ilyes512/$pkgname/archive/$pkgver.tar.gz")
-sha512sums=('fde934c2fab5ad06b1f02abb43423ffeb780cf1002a7348d08bf6d59a84cb4d7e460efa8cbe2261662e4d55cecb6fb396b36e1060afb9eda2568f2f1ad20d543')
-
+provides=("$_pkgbase")
+conflicts=("$_pkgbase")
+source=("git+https://github.com/timsolov/$_pkgbase.git")
+sha512sums=('SKIP')
+pkgver() {
+ cd "$srcdir/$_pkgbase"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
build() {
#build boilr binary
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$_pkgbase"
go build \
-trimpath \
@@ -30,5 +38,5 @@ build() {
package() {
# copy binary
- install -D -m 0755 "$srcdir/$pkgname-$pkgver/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -D -m 0755 "$srcdir/$_pkgbase/$_pkgbase" "$pkgdir/usr/bin/$_pkgbase"
}