summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD54
-rw-r--r--bombono-dvd-1.2.2-ffmpeg26.patch13
-rw-r--r--bombono-dvd.install13
-rw-r--r--fix_ffmpeg_codecid.patch47
5 files changed, 160 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8eeabeb0165
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = bombono-dvd
+ pkgdesc = DVD authoring program with nice and clean GUI
+ pkgver = 1.2.2
+ pkgrel = 4
+ url = http://www.bombono.org
+ install = bombono-dvd.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = scons
+ depends = gtk2
+ depends = gtkmm
+ depends = mjpegtools
+ depends = ffmpeg
+ depends = libdvdread
+ depends = dvdauthor
+ depends = dvd+rw-tools
+ depends = twolame
+ depends = libxml++
+ depends = boost
+ depends = enca
+ depends = cdrkit
+ optdepends = gvfs: web browser integration
+ conflicts = bombono-dvd-git
+ source = http://downloads.sourceforge.net/bombono/bombono-dvd-1.2.2.tar.bz2
+ source = fix_ffmpeg_codecid.patch
+ source = bombono-dvd-1.2.2-ffmpeg26.patch
+ sha256sums = 3ffaadc803dc2526d2805629ee928800ce150cb2e6a40b6724d898c76366f68b
+ sha256sums = decc8f9261b0fcd18780080438c9fc4297d56a281355f195a5dee9a92abf474a
+ sha256sums = ee89adeff7bd19d731eac96c180d5d59766bb3a68f3b21b898199e1cb6c5639e
+
+pkgname = bombono-dvd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be2ff7f54c19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# $Id: PKGBUILD
+# 2015.03.13 one more patch from gentoo
+
+pkgname=bombono-dvd
+pkgver=1.2.2
+pkgrel=4
+pkgdesc="DVD authoring program with nice and clean GUI"
+arch=('i686' 'x86_64')
+url="http://www.bombono.org"
+license=('GPL')
+depends=('gtk2' 'gtkmm' 'mjpegtools' 'ffmpeg' 'libdvdread' 'dvdauthor' \
+ 'dvd+rw-tools' 'twolame' 'libxml++' 'boost' 'enca' 'cdrkit')
+makedepends=('scons')
+optdepends=('gvfs: web browser integration')
+conflicts=('bombono-dvd-git')
+source=(http://downloads.sourceforge.net/bombono/$pkgname-$pkgver.tar.bz2
+ fix_ffmpeg_codecid.patch bombono-dvd-1.2.2-ffmpeg26.patch)
+install=bombono-dvd.install
+sha256sums=('3ffaadc803dc2526d2805629ee928800ce150cb2e6a40b6724d898c76366f68b'
+ 'decc8f9261b0fcd18780080438c9fc4297d56a281355f195a5dee9a92abf474a'
+ 'ee89adeff7bd19d731eac96c180d5d59766bb3a68f3b21b898199e1cb6c5639e')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/fix_ffmpeg_codecid.patch"
+ patch -Np1 -i "${srcdir}/bombono-dvd-1.2.2-ffmpeg26.patch"
+ # python2 fix
+ for file in $(find . -name '*.py' -print); do
+ sed -i 's_#!.*/usr/bin/python_#!/usr/bin/python2_' $file
+ sed -i 's_#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
+ done
+ for file in $(find . -name 'SConscript*' -print); do
+ sed -i 's_#!.*/usr/bin/python_#!/usr/bin/python2_' $file
+ sed -i 's_#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
+ done
+ for file in $(find . -name 'menu_SConscript*' -print); do
+ sed -i 's_#!.*/usr/bin/python_#!/usr/bin/python2_' $file
+ sed -i 's_#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
+ done
+ sed -i -e 's_#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' Autoconfig
+ for file in $(find . -name 'SConstruct*' -print); do
+ sed -i 's_#!.*/usr/bin/python_#!/usr/bin/python2_' $file
+ sed -i 's_#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
+ done
+
+ scons PREFIX="/usr" DESTDIR="$pkgdir" CPPFLAGS="-DBOOST_SYSTEM_NO_DEPRECATED -DBOOST_FILESYSTEM_VERSION=3" USE_EXT_BOOST=1
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ scons PREFIX="/usr" DESTDIR="$pkgdir" install
+}
+
diff --git a/bombono-dvd-1.2.2-ffmpeg26.patch b/bombono-dvd-1.2.2-ffmpeg26.patch
new file mode 100644
index 000000000000..b511a9d4ebd3
--- /dev/null
+++ b/bombono-dvd-1.2.2-ffmpeg26.patch
@@ -0,0 +1,13 @@
+Index: bombono-dvd-1.2.2/src/mgui/ffviewer.cpp
+===================================================================
+--- bombono-dvd-1.2.2.orig/src/mgui/ffviewer.cpp
++++ bombono-dvd-1.2.2/src/mgui/ffviewer.cpp
+@@ -1120,7 +1120,7 @@ static bool SeekSetTime(FFViewer& ffv, d
+ bool seek_ok = TimeSeek(ffv, start_time, time);
+ if( !seek_ok && CanByteSeek(ffv.iCtx) )
+ // тогда переходим в начало файла
+- seek_ok = DoSeek(ffv, ffv.iCtx->data_offset, true);
++ seek_ok = DoSeek(ffv, 0, true);
+
+ // некоторое видео глючит в начале (Hellboy), из-за чего
+ // последовательный доступ выполняется с перескоками -
diff --git a/bombono-dvd.install b/bombono-dvd.install
new file mode 100644
index 000000000000..82628b1f6fc7
--- /dev/null
+++ b/bombono-dvd.install
@@ -0,0 +1,13 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-mime-database usr/share/mime &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
diff --git a/fix_ffmpeg_codecid.patch b/fix_ffmpeg_codecid.patch
new file mode 100644
index 000000000000..08abbd0bebe3
--- /dev/null
+++ b/fix_ffmpeg_codecid.patch
@@ -0,0 +1,47 @@
+diff -u -r -N old/src/mgui/ffviewer.cpp new/src/mgui/ffviewer.cpp
+--- old/src/mgui/ffviewer.cpp 2013-03-07 22:20:45.000000000 +0100
++++ new/src/mgui/ffviewer.cpp 2013-08-14 08:56:12.917285000 +0200
+@@ -62,7 +62,7 @@
+
+ typedef struct AVCodecTag {
+ #if LIBAVFORMAT_VERSION_INT >= AV_VERSION_INT(52,39,00)
+- enum CodecID id;
++ enum AVCodecID id;
+ #else
+ int id;
+ #endif
+@@ -70,14 +70,14 @@
+ } AVCodecTag;
+
+ #if LIBAVFORMAT_VERSION_INT >= AV_VERSION_INT(52,34,00)
+-static uint FFCodecID2Tag(CodecID codec_id)
++static uint FFCodecID2Tag(AVCodecID codec_id)
+ {
+ unsigned int ff_codec_get_tag(const AVCodecTag *tags, int id);
+ extern const AVCodecTag ff_codec_bmp_tags[];
+ return ff_codec_get_tag(ff_codec_bmp_tags, codec_id);
+ }
+ #else
+-static uint FFCodecID2Tag(CodecID codec_id)
++static uint FFCodecID2Tag(AVCodecID codec_id)
+ {
+ unsigned int codec_get_tag(const AVCodecTag *tags, int id);
+ extern const AVCodecTag codec_bmp_tags[];
+@@ -388,7 +388,7 @@
+ return (tag>>bit_begin) & 0xFF;
+ }
+
+-static std::string CodecID2Str(CodecID codec_id)
++static std::string CodecID2Str(AVCodecID codec_id)
+ {
+ #ifdef _MSC_VER
+ std::string tag_str = boost::format("%1%") % codec_id % bf::stop;
+@@ -406,7 +406,7 @@
+
+ #else // CALC_FF_TAG
+
+-static std::string CodecID2Str(CodecID codec_id)
++static std::string CodecID2Str(AVCodecID codec_id)
+ {
+ return Int2Str(codec_id);
+ }