summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bbb2e53fd73..a92a25482c92 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bootstrap-dht-git
pkgdesc = Bittorrent DHT bootstrap server
- pkgver = r122.679c661
- pkgrel = 3
+ pkgver = r131.g679c661
+ pkgrel = 1
url = https://github.com/bittorrent/bootstrap-dht
arch = i686
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = bootstrap-dht-git
makedepends = boost
depends = glibc
depends = boost-libs
- provides = bootstrap-dht=r122.679c661
+ provides = bootstrap-dht=r131.g679c661
conflicts = bootstrap-dht
source = git+https://github.com/bittorrent/bootstrap-dht.git
source = boost.patch::https://github.com/bittorrent/bootstrap-dht/commit/131e4d2caccc227afa62837899123f424dccb296.patch
diff --git a/PKGBUILD b/PKGBUILD
index 525fa2f7053c..3d92ca6bc3d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=bootstrap-dht-git
-pkgver=r122.679c661
-pkgrel=3
+pkgver=r131.g679c661
+pkgrel=1
pkgdesc="Bittorrent DHT bootstrap server"
arch=('i686' 'x86_64')
url="https://github.com/bittorrent/bootstrap-dht"
@@ -26,7 +26,9 @@ prepare() {
pkgver() {
cd "bootstrap-dht"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ _rev=$(git rev-list --count --all)
+ _hash=$(git rev-parse --short HEAD)
+ printf "r%s.g%s" "$_rev" "$_hash"
}
build() {