summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD25
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d3f08f0098f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = bootstub-updater
+ pkgdesc = A utility to facilitate the maintenance of your EFI bootstub.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/RAR27/bootstub-updater
+ arch = x86_64
+ license = GPL3
+ makedepends = rust
+ source = bootstub-updater-1.0.0.tar.gz::https://github.com/RAR27/bootstub-updater/archive/v1.0.0.tar.gz
+ sha256sums = f318e65cb3ca8eede7e075f99058f714f47ed2678b53cde3cf50320a37b68a41
+
+pkgname = bootstub-updater
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76a878fbdca1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Rehan Rana <rehanalirana@tuta.io>
+
+pkgname=bootstub-updater
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='A utility to facilitate the maintenance of your EFI bootstub.'
+arch=('x86_64')
+url='https://github.com/RAR27/bootstub-updater'
+license=('GPL3')
+makedepends=('rust')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('f318e65cb3ca8eede7e075f99058f714f47ed2678b53cde3cf50320a37b68a41')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 target/release/$pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}