summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO47
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD59
3 files changed, 79 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6620e0cb510e..ac382644220e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,32 +1,49 @@
pkgbase = bottles
pkgdesc = Easily manage wine and proton prefix
- pkgver = 2021.9.14.28
- pkgrel = 1
- url = https://usebottles.com
- arch = any
+ pkgver = 51.11
+ pkgrel = 2
+ epoch = 2
+ url = https://github.com/bottlesdevs/Bottles
+ arch = x86_64
license = GPL3
makedepends = meson
makedepends = ninja
- depends = hicolor-icon-theme
+ makedepends = blueprint-compiler
+ depends = cabextract
depends = dconf
- depends = python
+ depends = fvs
+ depends = gtk4
+ depends = gtksourceview5
+ depends = hicolor-icon-theme
+ depends = icoextract
+ depends = imagemagick
+ depends = lib32-gnutls
+ depends = libadwaita
depends = libhandy
- depends = gtk3
- depends = patool
+ depends = libportal-gtk4
depends = p7zip
+ depends = patool
+ depends = python
+ depends = python-chardet
depends = python-gobject
+ depends = python-markdown
+ depends = python-orjson
+ depends = python-pathvalidate
+ depends = python-pycurl
depends = python-requests
+ depends = python-steamgriddb
depends = python-yaml
- depends = wine
- depends = cabextract
+ depends = webkit2gtk
+ depends = xorg-xdpyinfo
+ depends = vkbasalt-cli
+ optdepends = gamemode
optdepends = gvfs
- optdepends = vkd3d
optdepends = lib32-vkd3d
optdepends = lib32-vulkan-icd-loader
+ optdepends = vkd3d
optdepends = vulkan-icd-loader
- optdepends = gamemode
- source = bottles-2021.9.14-treviso.tar.gz::https://github.com/bottlesdevs/Bottles/archive/2021.9.14-treviso.tar.gz
- sha256sums = d66b9589164cd256064faefcb825d898c8e57099caddfca60267f67f93e65065
+ optdepends = wine
+ source = bottles-51.11.tar.gz::https://github.com/bottlesdevs/Bottles/archive/refs/tags/51.11.tar.gz
+ sha256sums = 3e438e98fdc3821e250a0c583e74d203e7c05511c0892587a5a29dd886392f3c
pkgname = bottles
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dd97d112957c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# Arch packages
+*.tar.zst
+
+# Bottles source code
+*.tar.gz
+
+# Packages build logs
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index 0015734e86b6..3c5af1d83cf4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,55 @@
# Maintaner: Francesco Masala <mail@francescomasala.me>
-# Contributor: Francesco Masala <mail@francescomasala.me>
+# Contributor: Francesco Masala <mail@francescomasala.me>
pkgname=bottles
-pkgver=2021.9.14
-pkgrel=1
+pkgver=51.11
+pkgrel=2
+epoch=2
pkgdesc='Easily manage wine and proton prefix'
arch=('x86_64')
url="https://github.com/bottlesdevs/Bottles"
license=('GPL3')
depends=(
- 'hicolor-icon-theme'
- 'dconf'
- 'python'
- 'libhandy'
- 'gtk3'
- 'patool'
- 'p7zip'
- 'python-gobject'
- 'python-requests'
- 'python-yaml'
- 'wine'
- 'cabextract')
+ 'cabextract'
+ 'dconf'
+ 'fvs'
+ 'gtk4'
+ 'gtksourceview5'
+ 'hicolor-icon-theme'
+ 'icoextract'
+ 'imagemagick'
+ 'lib32-gnutls'
+ 'libadwaita'
+ 'libhandy'
+ 'libportal-gtk4'
+ 'p7zip'
+ 'patool'
+ 'python'
+ 'python-chardet'
+ 'python-gobject'
+ 'python-markdown'
+ 'python-orjson'
+ 'python-pathvalidate'
+ 'python-pycurl'
+ 'python-requests'
+ 'python-steamgriddb'
+ 'python-yaml'
+ 'webkit2gtk'
+ 'xorg-xdpyinfo'
+ 'vkbasalt-cli'
+)
optdepends=(
+ 'gamemode'
'gvfs'
- 'vkd3d'
'lib32-vkd3d'
'lib32-vulkan-icd-loader'
+ 'vkd3d'
'vulkan-icd-loader'
- 'gamemode')
-makedepends=('meson' 'ninja')
-source=("${pkgname}-${pkgver}-treviso.tar.gz::https://github.com/bottlesdevs/Bottles/archive/${pkgver}-treviso.tar.gz")
-sha256sums=('d66b9589164cd256064faefcb825d898c8e57099caddfca60267f67f93e65065')
+ 'wine'
+)
+makedepends=('meson' 'ninja' 'blueprint-compiler')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/bottlesdevs/Bottles/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('3e438e98fdc3821e250a0c583e74d203e7c05511c0892587a5a29dd886392f3c')
build() {
if [[ -d Bottles ]]; then