summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 29 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f3c243d3594..6b9007e64274 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = bpkg-git
pkgdesc = Lightweight bash package manager
- pkgver = 0.2.9.1.g72c9a90
+ pkgver = 1.1.3.bd8c92f
pkgrel = 1
- url = https://bpkg.io
+ url = http://www.bpkg.sh/
arch = any
license = MIT
makedepends = git
depends = bash
provides = bpkg
conflicts = bpkg
- source = git+https://github.com/bpkg/bpkg
+ source = bpkg::git+https://github.com/bpkg/bpkg
md5sums = SKIP
pkgname = bpkg-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0eb7fbfc4dfb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.*
+bpkg/
diff --git a/PKGBUILD b/PKGBUILD
index 134ac6383b07..d00dcb6d380f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,44 @@
-# Maintainer: Marcos Ferreira <merkkp at gmail dot com>
+# Maintainer: richard-muvirimi <tygalive at gmail dot com>
+# Contributor: scrouthtv <scrouthtv 0x40 gmail 0x2e com>
+# Contributor: Marcos Ferreira <merkkp at gmail dot com>
_gitname="bpkg"
+
pkgname="${_gitname}-git"
-pkgver=0.2.9.1.g72c9a90
+pkgver=1.1.3.bd8c92f
pkgrel=1
pkgdesc="Lightweight bash package manager"
arch=("any")
-url="https://bpkg.io"
+url="http://www.bpkg.sh/"
license=("MIT")
depends=("bash")
makedepends=("git")
provides=("${_gitname}")
conflicts=("${_gitname}")
-source=("git+https://github.com/bpkg/${_gitname}")
+source=("${_gitname}::git+https://github.com/${_gitname}/${_gitname}")
md5sums=("SKIP")
pkgver() {
cd "${_gitname}"
- git describe --tags --long | sed 's/^v//;s/-/./;s/-/./g'
+
+ TAG="$(git describe --tags $(git rev-list --tags --max-count=1) | sed 's/-/.r/;s/-/./')"
+ HASH="$(git describe --tags --long --always | sed 's/\([^-]*-g\)/r\1/;s/-/./g')"
+
+ # Outputs something like: 1.1.3.bd8c92f
+ echo "$TAG.$HASH"
+}
+
+build(){
+ cd "${srcdir}/${_gitname}"
+
+ # Check out latest tag
+ git fetch --tags
+ git checkout "$(git describe --tags $(git rev-list --tags --max-count=1))"
}
package() {
cd "${srcdir}/${_gitname}"
+
PREFIX="${pkgdir}/usr" ./setup.sh
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}