summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--Makefile5
-rw-r--r--PKGBUILD14
4 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10af7f438454
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = brother-dcp-t710w-lpr-bin
+ pkgdesc = LPR driver for Brother DCP-T710W printer
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://support.brother.com/g/b/downloadlist.aspx?c=pl&lang=pl&prod=dcpt710w_all&os=128&flang=English
+ arch = i686
+ arch = x86_64
+ groups = base-devel
+ license = EULA
+ source = https://download.brother.com/welcome/dlf103622/dcpt710wpdrv-1.0.0-0.i386.deb
+ md5sums = 7dc8dce64785fd3c47cb02547692c3a9
+
+pkgname = brother-dcp-t710w-lpr-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4db48576517b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!Makefile
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..a1451de8802d
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,5 @@
+.PHONY: all
+all: .SRCINFO
+
+.SRCINFO: PKGBUILD
+ makepkg --printsrcinfo > .SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c67b0a669e7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,14 @@
+# Maintainer: Radoslaw Mejer <radmen@radmen.info>
+pkgname=brother-dcp-t710w-lpr-bin
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="LPR driver for Brother DCP-T710W printer"
+arch=("i686" "x86_64")
+url="https://support.brother.com/g/b/downloadlist.aspx?c=pl&lang=pl&prod=dcpt710w_all&os=128&flang=English"
+license=("EULA")
+groups=("base-devel")
+source=("https://download.brother.com/welcome/dlf103622/dcpt710wpdrv-1.0.0-0.i386.deb")
+md5sums=("7dc8dce64785fd3c47cb02547692c3a9")
+package() {
+ tar -xf data.tar.gz -C "${pkgdir}"
+}