summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2917ebd6fb03
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = brother-dcpl2510d
+ pkgdesc = LPR driver and CUPS wrapper for the Brother DCP-L2510D and DCP-L2512D printers
+ pkgver = 4.0.0_1
+ pkgrel = 1
+ url = https://support.brother.com/g/b/downloadtop.aspx?c=eu_ot&lang=en&prod=dcpl2512d_eu
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = custom:brother
+ depends = cups
+ optdepends = brscan4: scanner support.
+ source = http://download.brother.com/welcome/dlf103515/dcpl2510dpdrv-4.0.0-1.i386.rpm
+ md5sums = d893177416b0da4ccaaadf3278b9d298
+
+pkgname = brother-dcpl2510d
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4a52c7c0e7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Rokic <Rokicc@proton.me>
+# Based on brother-dcpl2530dw package from AUR.
+
+pkgname=brother-dcpl2510d
+pkgver=4.0.0_1
+pkgrel=1
+pkgdesc="LPR driver and CUPS wrapper for the Brother DCP-L2510D and DCP-L2512D printers"
+arch=('i686' 'x86_64')
+url="https://support.brother.com/g/b/downloadtop.aspx?c=eu_ot&lang=en&prod=dcpl2512d_eu"
+license=('GPL2' 'custom:brother')
+depends=('cups')
+optdepends=('brscan4: scanner support.')
+source=(
+ "http://download.brother.com/welcome/dlf103515/dcpl2510dpdrv-${pkgver/_/-}.i386.rpm"
+)
+md5sums=(
+ 'd893177416b0da4ccaaadf3278b9d298'
+)
+
+prepare() {
+ sed -i -e '75c\my $basedir = "/opt/brother/Printers/DCPL2510D";' \
+ ${srcdir}/opt/brother/Printers/DCPL2510D/cupswrapper/lpdwrapper
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/cups/model/Brother
+ mkdir -p ${pkgdir}/usr/lib/cups/filter
+ cp ${srcdir}/opt/brother/Printers/DCPL2510D/cupswrapper/brother-DCPL2510D-cups-en.ppd ${pkgdir}/usr/share/cups/model/Brother
+ cp ${srcdir}/opt/brother/Printers/DCPL2510D/cupswrapper/lpdwrapper ${pkgdir}/usr/lib/cups/filter/brother_lpdwrapper_DCPL2510D
+
+ mkdir -p ${pkgdir}/opt/brother/Printers/DCPL2510D/lpd/
+ cp -r ${srcdir}/opt/brother/Printers/DCPL2510D/inf ${pkgdir}/opt/brother/Printers/DCPL2510D/
+ cp ${srcdir}/opt/brother/Printers/DCPL2510D/lpd/lpdfilter ${pkgdir}/opt/brother/Printers/DCPL2510D/lpd/
+ cp ${srcdir}/opt/brother/Printers/DCPL2510D/lpd/${CARCH}/* ${pkgdir}/opt/brother/Printers/DCPL2510D/lpd/
+ cp -r ${srcdir}/var ${pkgdir}/
+}