summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--LICENSE7
-rw-r--r--PKGBUILD36
-rw-r--r--brother-dcpt700w.install27
-rw-r--r--fix_lp.patch11
5 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..614e9104ab09
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = brother-dcpt700w
+ pkgdesc = Driver for the Brother DCP-T700W wifi multifuncional printer
+ pkgver = 3.0.2
+ pkgrel = 1
+ url = http://solutions.brother.com/linux/en_us/index.html
+ install = brother-dcpt700w.install
+ arch = i686
+ arch = x86_64
+ license = custom:brother EULA
+ depends = cups
+ optdepends = brscan4
+ source = fix_lp.patch
+ source = LICENSE
+ source = http://download.brother.com/welcome/dlf101950/dcpt700wlpr-3.0.2-0.i386.rpm
+ source = http://download.brother.com/welcome/dlf101951/dcpt700wcupswrapper-3.0.2-0.i386.rpm
+ md5sums = 9cd6cc312202017e2273a227d7dfc2ff
+ md5sums = 894d2fffe51badc93ebc0ac433317925
+ md5sums = bcd62b9be7bd1707cd243ac184f794b8
+ md5sums = dd4c03ea11be0b570cfe6be0b69c9625
+ depends_x86_64 = lib32-glibc
+
+pkgname = brother-dcpt700w
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..986198f780e0
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,7 @@
+This Agreement provides terms and conditions for license grant from Brother Industries, Ltd ("Brother"). Brother, who owns all copyrights to the software that is distributed with this Agreement ("Software") to recipients thereof ("User"), for use of the Software. User shall have the right to use the Software only in accordance with the terms and conditions of this Agreement. Any use by User of the Software shall be deemed as its agreement hereto.
+
+Brother retains any and all copyrights to the Software. In no case this Agreement shall be construed to assign or otherwise transfer from Brother to User any copyrights or other intellectual property rights to whole or any part of the Software.
+
+Brother grants User a non-exclusive license: to reproduce and/or distribute (via Internet or in any other manner) the Software. Further, Brother grants User a non-exclusive license to modify, alter, translate or otherwise prepare derivative works of the Software and to reproduce and distribute (via Internet or in any other manner) such modification, alteration, translation or other derivative works for any purpose.
+
+The license of the Software from Brother hereunder is granted "AS IS." BROTHER HEREBY DISCLAIMS ANY WARRANTIES WITH RESPECT TO THE SOFTWARE, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO WARRANTY FOR THE QUALITY, MERCHANTABILITY, FITNESS FOR PARTICULAR PURPOSE OR NON-INFRINGEMENT. Brother shall have no liability in contract, tort (including negligence or breach of statutory duty) or otherwise for any interruption of use, loss of data, or for any indirect, incidental, punitive or consequential loss or damage, or for any loss of profit, revenue, data, goodwill or anticipated savings that arises under, out of, or in contemplation of this Agreement or otherwise arises due to any error, inaccuracy or defect in the Software even if Brother has been advised of the possibility of such loss or damage. Further, Brother shall have no liability to disclose and/or distribute the source code of the Software to User under any circumstances. In no case shall the above license by Brother to modify, alter, translate or otherwise prepare derivative works of the Software be construed as Brother's implied agreement or undertakings to disclose and/or distribute the source code of the Software.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17312c4f23ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Fabio Loli <loli_fabio@protonmail.com>
+# Based on brother-dcpt500w by Samuel Fernando Mesa Giraldo
+# https://github.com/FabioLolix
+
+pkgname=brother-dcpt700w
+pkgver=3.0.2
+pkgrel=1
+pkgdesc="Driver for the Brother DCP-T700W wifi multifuncional printer"
+arch=('i686' 'x86_64')
+url="http://solutions.brother.com/linux/en_us/index.html"
+license=('custom:brother EULA')
+depends=('cups')
+depends_x86_64=('lib32-glibc')
+optdepends=('brscan4')
+install="${pkgname}.install"
+source=('fix_lp.patch'
+ 'LICENSE'
+ "http://download.brother.com/welcome/dlf101950/dcpt700wlpr-$pkgver-0.i386.rpm"
+ "http://download.brother.com/welcome/dlf101951/dcpt700wcupswrapper-$pkgver-0.i386.rpm")
+md5sums=('9cd6cc312202017e2273a227d7dfc2ff'
+ '894d2fffe51badc93ebc0ac433317925'
+ 'bcd62b9be7bd1707cd243ac184f794b8'
+ 'dd4c03ea11be0b570cfe6be0b69c9625')
+
+build() {
+ cd "$srcdir"
+ patch -Np0 < fix_lp.patch
+}
+
+package(){
+ install -d $pkgdir/usr/bin
+ install -d $pkgdir/var/spool/lpd
+ install -Dm755 "$srcdir"/usr/bin/brprintconf_dcpt700w "$pkgdir"/usr/bin/
+ cp -R $srcdir/opt $pkgdir/opt
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/brother-dcpt700w.install b/brother-dcpt700w.install
new file mode 100644
index 000000000000..ed48e791bf5f
--- /dev/null
+++ b/brother-dcpt700w.install
@@ -0,0 +1,27 @@
+post_install() {
+ # lpr
+ /opt/brother/Printers/dcpt700w/inf/setupPrintcapij dcpt700w -i
+
+ # cupswrapper
+ /opt/brother/Printers/dcpt700w/cupswrapper/cupswrapperdcpt700w
+
+ systemctl restart org.cups.cupsd.service
+}
+
+post_upgrade() {
+ /bin/true
+}
+
+pre_remove() {
+ # lpr
+ /opt/brother/Printers/dcpt700w/inf/setupPrintcapij dcpt700w -e
+
+ # cupswrapper
+ /opt/brother/Printers/dcpt700w/cupswrapper/cupswrapperdcpt700w -e
+}
+
+op=$1
+shift
+
+$op "$@"
+
diff --git a/fix_lp.patch b/fix_lp.patch
new file mode 100644
index 000000000000..039a4e8e1964
--- /dev/null
+++ b/fix_lp.patch
@@ -0,0 +1,11 @@
+--- opt/brother/Printers/dcpt700w/inf/setupPrintcapij.old 2008-09-15 22:01:07.000000000 +0200
++++ opt/brother/Printers/dcpt700w/inf/setupPrintcapij 2008-09-15 22:01:26.000000000 +0200
+@@ -34,7 +34,7 @@
+ if [ ! -d $SPOOLER_NAME ]; then
+ mkdir $SPOOLER_NAME
+ fi
+- chown lp $SPOOLER_NAME
++ chown root $SPOOLER_NAME
+ chgrp lp $SPOOLER_NAME
+ chmod 700 $SPOOLER_NAME
+