summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD8
3 files changed, 15 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62cde7977a5a..b40c69d1666f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Thu Nov 9 19:42:17 UTC 2017
pkgbase = brother-hl5470dw
pkgdesc = LPR and CUPS driver for the Brother HL5470DW
pkgver = 3.0.0
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..74eb51554b0f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg
+src
+*.zip
+*.tar*
+*.rpm
diff --git a/PKGBUILD b/PKGBUILD
index 68106f5fa6f3..4a3f3dd1a5d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Pascal Potvin <pascal.potvin AT gmail DOT com>
+# Contributor: A Frederick Christensen <aurlinux@nosocomia.com>
pkgname="brother-hl5470dw"
pkgver="3.0.0"
pkgrel=1
@@ -59,11 +60,18 @@ prepare() {
package() {
cp -R $srcdir/usr $pkgdir
+ #We need the .ppd in the right place (expected by the filter)
+ cp $srcdir/opt/brother/Printers/HL5470DW/cupswrapper/brother-HL-5470DW-cups-en.ppd $pkgdir/usr/share/cups/model/HL5470DW.ppd
+
#We need to install the filter file to the cups filter path, so the PPD can find it
mkdir -p $pkgdir/usr/lib/cups/filter
cp $srcdir/opt/brother/Printers/HL5470DW/cupswrapper/brother_lpdwrapper_HL5470DW \
$pkgdir/usr/lib/cups/filter
+ #Keep /var/spool/lpd locking working correctly
+ mkdir -p $pkgdir/var/spool/lpd/HL5470DW
+ chmod 755 $pkgdir/var/spool/lpd/HL5470DW
+
if [ -d $srcdir/opt ]; then
cp -R $srcdir/opt $pkgdir;
fi