summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 432a7dd5d8ee..0746e0f6a1e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
# Generated by mksrcinfo v8
-# Thu Feb 22 15:52:59 UTC 2018
+# Thu Apr 18 12:25:03 UTC 2019
pkgbase = brother-mfc-j625dw
pkgdesc = LPR and CUPS driver for the Brother MFC-J625DW
pkgver = 3.0
- pkgrel = 3
+ pkgrel = 4
url = http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html
install = brother-mfc-j625dw.install
arch = i686
arch = x86_64
license = unknown
- depends = tcsh
- depends = perl
- depends = a2ps
+ makedepends = perl
+ depends = bash
source = http://www.brother.com/pub/bsc/linux/dlf/mfcj625dwlpr-3.0.1-1.i386.deb
source = http://www.brother.com/pub/bsc/linux/dlf/mfcj625dwcupswrapper-3.0.0-1.i386.deb
md5sums = 73b9a05efb33f895e5ffe2f3c4c01fdc
diff --git a/PKGBUILD b/PKGBUILD
index d2c74b54b5a3..a129b1f8fa8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,16 @@
_model="j625dw"
pkgname="brother-mfc-$_model"
pkgver="3.0"
-pkgrel=3
+pkgrel=4
pkgdesc="LPR and CUPS driver for the Brother MFC-J625DW"
arch=('i686' 'x86_64')
url="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html"
license=('unknown')
-depends=('tcsh' 'perl' 'a2ps')
+depends=('bash')
if test "$CARCH" == x86_64; then
depends+=(lib32-glibc)
fi
+makedepends=('perl')
install="brother-mfc-${_model}.install"
_revision=1
source=("http://www.brother.com/pub/bsc/linux/dlf/mfc${_model}lpr-${pkgver}.1-${_revision}.i386.deb"
@@ -22,15 +23,15 @@ md5sums=('73b9a05efb33f895e5ffe2f3c4c01fdc'
'a4a35a5ad3cfd3bb016941afff79425e')
build() {
- deb2targz *.deb >/dev/null || return 1
- rm -f *.deb || return 1
cd $srcdir || return 1
[ -d "mfc${_model}" ] || (mkdir mfc${_model} || return 1)
- for i in *.tar.gz;do tar xfz $i -C mfc${_model};done || return 1
+ ar p mfc${_model}lpr-${pkgver}.1-${_revision}.i386.deb data.tar.gz | tar zx -C mfc${_model}|| return 1
+ ar p mfc${_model}cupswrapper-${pkgver}.0-${_revision}.i386.deb data.tar.gz | tar zx -C mfc${_model} || return 1
cd mfc${_model} || return 1
cd opt/brother/Printers/mfc${_model} || return 1
perl -i -pe 's#/etc/init.d#/etc/rc.d#g' ./cupswrapper/cupswrappermfc${_model} || return 1
perl -i -pe 's#printcap\.local#printcap#g' $srcdir/mfc${_model}/opt/brother/Printers/mfc${_model}/inf/setupPrintcapij || return 1
+ rm -f *.deb || return 1
}
package() {