summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52a667664842
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = btrfs-sync
+ pkgdesc = Smart and easy sync of BTRFS snapshots, locally or through SSH.
+ pkgver = 16
+ pkgrel = 1
+ url = https://github.com/nachoparker/btrfs-sync
+ arch = any
+ license = GPL3
+ depends = btrfs-progs
+ optdepends = openssh: for openssh support.
+ optdepends = pv: allows a user to see the progress of data through a pipeline.
+ optdepends = pbzip2: parallel bzip2 file compression.
+ source = git+https://github.com/nachoparker/btrfs-sync.git
+ md5sums = SKIP
+
+pkgname = btrfs-sync
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc735db3a5b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+#Maintainer: InvisibleRasta <nicolast88[at]gmail[dot]com>
+pkgname=btrfs-sync
+pkgver=16
+pkgrel=1
+pkgdesc="Smart and easy sync of BTRFS snapshots, locally or through SSH."
+arch=('any')
+url="https://github.com/nachoparker/btrfs-sync"
+license=('GPL3')
+source=("git+https://github.com/nachoparker/${pkgname}.git")
+md5sums=('SKIP')
+depends=('btrfs-progs')
+optdepends=(
+ 'openssh: for openssh support.'
+ 'pv: allows a user to see the progress of data through a pipeline.'
+ 'pbzip2: parallel bzip2 file compression.'
+)
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "$(git rev-list --count HEAD)"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm 755 ${pkgname} "$pkgdir/usr/bin/${pkgname}"
+}