summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..632dd277ee37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = budgie-visualspace-git
+ pkgdesc = Budgie dynamic workspaces and visualizer script
+ pkgver = v0.6.1.r56.g05fda7f
+ pkgrel = 1
+ arch = any
+ license = GPL3
+ depends = budgie-desktop
+ depends = budgie-extras
+ source = budgie-extras::git+https://github.com/UbuntuBudgie/budgie-extras
+ sha256sums = SKIP
+
+pkgname = budgie-visualspace-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09b006a450e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=budgie-visualspace-git
+pkgver=v0.6.1.r56.g05fda7f
+pkgrel=1
+pkgdesc="Budgie dynamic workspaces and visualizer script"
+arch=('any')
+license=('GPL3')
+depends=('budgie-desktop' 'budgie-extras')
+source=('budgie-extras::git+https://github.com/UbuntuBudgie/budgie-extras')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/budgie-extras/budgie_visualspace"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/budgie-extras/budgie_visualspace"
+ rm README.md
+ rm visualspace.png
+ mkdir -p "${pkgdir}/usr/share/glib-2.0/schemas/"
+ cp schema/* "${pkgdir}/usr/share/glib-2.0/schemas/"
+ rm -rf schema
+ mkdir -p "${pkgdir}/usr/share/budgie-desktop/visualspace/"
+ cp ./* "${pkgdir}/usr/share/budgie-desktop/visualspace/"
+}