summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e03776656cf6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = bugmenot
+ pkgdesc = An unofficial Python package to retrieve credentials from BugMeNot.com
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/ptrstn/bugmenot
+ arch = any
+ license = Unlicense
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/ptrstn/bugmenot/archive/refs/tags/v0.1.tar.gz
+ sha256sums = 0e51c3db0e25626553b98f25e23948a7c4c65ab9a031b9e7dcc20ec9a0ba7647
+
+pkgname = bugmenot
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1693ecdbbfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Maxwell Pray <synthead@gmail.com>
+
+pkgname=bugmenot
+pkgver=0.1
+pkgrel=1
+pkgdesc="An unofficial Python package to retrieve credentials from BugMeNot.com"
+arch=("any")
+url="https://github.com/ptrstn/bugmenot"
+license=("Unlicense")
+makedepends=("python-setuptools")
+depends=("python")
+source=("https://github.com/ptrstn/bugmenot/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=("0e51c3db0e25626553b98f25e23948a7c4c65ab9a031b9e7dcc20ec9a0ba7647")
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ python setup.py install --root="$pkgdir/" --optimize=1
+}