aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xarch.build4
3 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index def1d460379c..4f9dfaefe7a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = buildstuff
pkgdesc = Stuff to build packages in virtual machines
pkgver = 1.6
- pkgrel = 1
+ pkgrel = 2
url = http://arch.vesath.org/
arch = any
license = custom:ISC
@@ -16,7 +16,7 @@ pkgbase = buildstuff
source = arch.install
sha256sums = 6225e9cd7dbd46692d3b3ebde37a182c05863459879e99dbca5b3a4125e5eb1d
sha256sums = acf683446e1162104759b1a75d18859b1a36ac6f3eeabb241025d0e6c37c7960
- sha256sums = 42f56cebdfde7a6b4f2beb3917856d3eb37206f05f443468b6c0ddafa3dbf3a3
+ sha256sums = 12b438eaa95d48db7a9ff5a2c5e6af542548752e293fca6d824f2437a59fc5f2
sha256sums = ec9d9974fc65a670754f66aa16b6f64394fbf089685acae32e31d3727263f3ee
pkgname = buildstuff
diff --git a/PKGBUILD b/PKGBUILD
index 82f0d8b44bcf..00ea8472c8d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=buildstuff
pkgver=1.6
-pkgrel=1
+pkgrel=2
pkgdesc='Stuff to build packages in virtual machines'
url='http://arch.vesath.org/'
arch=('any')
@@ -25,5 +25,5 @@ package() {
sha256sums=('6225e9cd7dbd46692d3b3ebde37a182c05863459879e99dbca5b3a4125e5eb1d'
'acf683446e1162104759b1a75d18859b1a36ac6f3eeabb241025d0e6c37c7960'
- '42f56cebdfde7a6b4f2beb3917856d3eb37206f05f443468b6c0ddafa3dbf3a3'
+ '12b438eaa95d48db7a9ff5a2c5e6af542548752e293fca6d824f2437a59fc5f2'
'ec9d9974fc65a670754f66aa16b6f64394fbf089685acae32e31d3727263f3ee')
diff --git a/arch.build b/arch.build
index ada45e0f4336..53f937ca78f3 100755
--- a/arch.build
+++ b/arch.build
@@ -79,11 +79,11 @@ for r in $repo; do
done | ssh $vhost
ssh $vhost 'sudo pacman --noconfirm -Syu'
ssh $vhost 'sudo pacman --noconfirm -Su'
+ssh $vhost 'sudo install -o user -g user -d /build'
sftp $vhost <<<"mkdir .gnupg"
sftp $vhost <<<"put $HOME/.makepkg.conf"
sftp $vhost <<<"put $HOME/.gnupg/pubring.kbx .gnupg/pubring.kbx"
-sftp $vhost <<<'put -r . build'
-ssh $vhost 'sudo mv build /build' # fake chroot build for db-update
+sftp $vhost <<<'put -r . /build' # fake chroot build for db-update
ssh $vhost 'rm -fr /build/{src,pkg}' # fix source repo relocation
ssh $vhost 'cd /build; makepkg --log --noconfirm --syncdeps'
sftp $vhost <<<'get /build/*.pkg.tar.xz'