summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b74763cc9296
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = bypass4netns
+ pkgdesc = Accelerates slirp4netns using SECCOMP_IOCTL_NOTIF_ADDFD. As fast as --net=host.
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://github.com/rootless-containers/bypass4netns
+ arch = x86_64
+ license = Apache-2.0
+ makedepends = git
+ makedepends = go
+ depends = slirp4netns
+ provides = bypass4netns=0.4.1
+ conflicts = bypass4netns
+ source = bypass4netns-0.4.1.tar.gz::https://github.com/rootless-containers/bypass4netns/archive/v0.4.1.tar.gz
+ validpgpkeys = 49524C6F9F638F1A
+ sha256sums = 60e8c4b0d4c67c374dc48273727ca3f6c0fe217b8abf1bbc5b426d529c568cb4
+
+pkgname = bypass4netns
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..209eaaefe67f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13ddadf3bca2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: merrkry <jeffpotvin930@gmail.com>
+
+_pkgname="bypass4netns"
+pkgname="${_pkgname}"
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="Accelerates slirp4netns using SECCOMP_IOCTL_NOTIF_ADDFD. As fast as --net=host."
+arch=("x86_64")
+url="https://github.com/rootless-containers/bypass4netns"
+license=("Apache-2.0")
+depends=("slirp4netns")
+makedepends=("git" "go")
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/rootless-containers/bypass4netns/archive/v$pkgver.tar.gz")
+validpgpkeys=("49524C6F9F638F1A")
+sha256sums=("60e8c4b0d4c67c374dc48273727ca3f6c0fe217b8abf1bbc5b426d529c568cb4")
+
+build() {
+ cd $_pkgname-$pkgver
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ install -Dm755 "bypass4netns" "$pkgdir/usr/bin/bypass4netns"
+ install -Dm755 "bypass4netnsd" "$pkgdir/usr/bin/bypass4netnsd"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+} \ No newline at end of file