summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6438bd14f74
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = bython
+ pkgdesc = Python with braces. Because Python is awesome, but whitespace is awful.
+ pkgver = 0.8
+ pkgrel = 1
+ url = https://github.com/mathialo/bython
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ source = https://files.pythonhosted.org/packages/9f/b1/b0af10aac41ddb0a0911f47d282f45633cc1fa72e7b5a240cb2673ca0115/bython-0.8.tar.gz
+ sha512sums = d4f424a4ca01eeda33d654b35e946b33db22ecaa52f8abe82808e5f085c509ac3bf74174b968f6c72be662e5618f2a087e2346fd12b7db513dfa0a7d121c02f6
+
+pkgname = bython
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..047166522cbe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Storm Dragon <storm_dragon@linux-a11y.org>
+
+pkgname='bython'
+pkgver=0.8
+pkgrel=1
+pkgdesc="Python with braces. Because Python is awesome, but whitespace is awful."
+url="https://github.com/mathialo/bython"
+license=('MIT')
+arch=('any')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/9f/b1/b0af10aac41ddb0a0911f47d282f45633cc1fa72e7b5a240cb2673ca0115/bython-${pkgver}.tar.gz")
+sha512sums=('d4f424a4ca01eeda33d654b35e946b33db22ecaa52f8abe82808e5f085c509ac3bf74174b968f6c72be662e5618f2a087e2346fd12b7db513dfa0a7d121c02f6')
+
+package() {
+ cd "${srcdir}/bython-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+