summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--str-mark.diff13
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb296fd26973
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = bzr-fastimport
+ pkgdesc = Bazaar Fast Import is a plugin providing fast loading of revision control data into Bazaar
+ pkgver = 0.14.0.r361
+ pkgrel = 2
+ url = https://launchpad.net/bzr-fastimport
+ arch = any
+ license = GPL2
+ depends = bzr
+ depends = python2-fastimport
+ source = bzr-fastimport::bzr+lp:bzr-fastimport#revision=360
+ source = str-mark.diff
+ sha256sums = SKIP
+ sha256sums = d7e2f7c088570d9f9482bf4bba97885cf262260737b87c0ebb1122234331aeb6
+
+pkgname = bzr-fastimport
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f19bbe11ef1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Martin Wimpress <code@flexion.org>
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=bzr-fastimport
+pkgver=0.14.0.r361
+pkgrel=2
+pkgdesc='Bazaar Fast Import is a plugin providing fast loading of revision control data into Bazaar'
+arch=('any')
+url='https://launchpad.net/bzr-fastimport'
+license=('GPL2')
+depends=('bzr' 'python2-fastimport')
+source=("${pkgname}::bzr+lp:bzr-fastimport#revision=360"
+ "str-mark.diff")
+sha256sums=('SKIP'
+ 'd7e2f7c088570d9f9482bf4bba97885cf262260737b87c0ebb1122234331aeb6')
+
+prepare() {
+ cd ${pkgname}
+
+ patch -p1 < ../str-mark.diff
+}
+
+package() {
+ cd ${pkgname}
+
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/str-mark.diff b/str-mark.diff
new file mode 100644
index 000000000000..c39262d29e49
--- /dev/null
+++ b/str-mark.diff
@@ -0,0 +1,13 @@
+=== modified file 'exporter.py'
+--- old/exporter.py 2014-05-15 09:26:03 +0000
++++ new/exporter.py 2017-12-27 17:01:10 +0000
+@@ -436,7 +436,7 @@
+ pass
+
+ # Build and return the result
+- return commands.CommitCommand(git_ref, mark, author_info,
++ return commands.CommitCommand(git_ref, str(mark), author_info,
+ committer_info, revobj.message.encode("utf-8"), from_, merges, iter(file_cmds),
+ more_authors=more_author_info, properties=properties)
+
+